summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2021-11-12 10:17:28 +0200
committerSam James <sam@gentoo.org>2021-11-22 10:05:23 +0000
commit1d7c46027db94bd5b8daefb52e1013a20edaf63e (patch)
tree789a08a4f19e8ed981078f37994a988598aff44a
parentwww-client/surf: drop 2.0-r1 (diff)
downloadgentoo-1d7c46027db94bd5b8daefb52e1013a20edaf63e.tar.gz
gentoo-1d7c46027db94bd5b8daefb52e1013a20edaf63e.tar.bz2
gentoo-1d7c46027db94bd5b8daefb52e1013a20edaf63e.zip
sys-cluster/glusterfs: v9.4 (stable target)
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/glusterfs/Manifest1
-rw-r--r--sys-cluster/glusterfs/glusterfs-9.4.ebuild195
2 files changed, 196 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/Manifest b/sys-cluster/glusterfs/Manifest
index a7d6acbfcbfe..36ce8aea0069 100644
--- a/sys-cluster/glusterfs/Manifest
+++ b/sys-cluster/glusterfs/Manifest
@@ -6,3 +6,4 @@ DIST glusterfs-8.6.tar.gz 7826147 BLAKE2B 3a8a488c9a8e4b1daf3ed01fa5e52a62cf7913
DIST glusterfs-9.1.tar.gz 8206207 BLAKE2B dea099eb1d366704010247964c24de404fb09c00a375dde4af30a2af836d3b35689fab91a75268aa01dba45860eb50a6e0572913c059e53fb5799d2302c2f005 SHA512 2c26813f12fed7a0640cc470badc2b83f156b660ef475487a689dca6c3fa407192f4959aeaf7a981969a079cf5d2c7aace85ff818ea6133d5a085d90d226e1da
DIST glusterfs-9.2.tar.gz 8212980 BLAKE2B 7fb42186c5d309c357f72e3037fc09d8b15f32770d74173dd4779bab91056d1ceb78a4a651fec2018faf1597357576d41593e9d7b04cf9af7f4742301b284b01 SHA512 34a0a1745029e2fad3c8fc6a044b4e4645f8cf11eddc3c8c8e94cce9733449248c577ce6066bc49010a65121d991daf67766393fe513ac694082f0efa1d4ef95
DIST glusterfs-9.3.tar.gz 8167846 BLAKE2B 119e2c089ef250fafb2b2dfdcf71f40cc25fdda6ac1cbb38a8557a3c206f721227eceadd87b40341e6bf2b32a7cb24996910f45e061f25d193ab2ca4070ddc76 SHA512 0974cf57a6810505f767c490b53201e62bb73ca2fd3c5203d9882dcbe4088c816afb5445ef606d12fb797b1b1fa5e0994f2ea0816577f70e630637668a20f005
+DIST glusterfs-9.4.tar.gz 8173625 BLAKE2B c35c63696717bf09f8fbf77dca16a6f45de278253e768c6ffc40c0c097da9ea1b32888233da412a5333281995e89e08d9ed23fd47aba7c506de84b08f9f80cea SHA512 2a17197bd2b425117e34af004a6177b7c5012807cd99b9c6d37a1081e0ab9def6b013bedd0ba4122d149969755e0e2985bef8aed9cf612a27a6452b8719a33bf
diff --git a/sys-cluster/glusterfs/glusterfs-9.4.ebuild b/sys-cluster/glusterfs/glusterfs-9.4.ebuild
new file mode 100644
index 000000000000..a259a27a6aa4
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-9.4.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools elisp-common python-single-r1 tmpfiles
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/ https://github.com/gluster/glusterfs/"
+SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0/${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE="debug emacs +fuse +georeplication ipv6 +libtirpc rsyslog static-libs +syslog test +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} xml )
+ ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ net-libs/rpcsvc-proto
+ sys-apps/util-linux
+ sys-libs/liburing:=
+ sys-libs/readline:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ fuse? ( >=sys-fs/fuse-2.7.0:0 )
+ georeplication? ( ${PYTHON_DEPS} )
+ xml? ( dev-libs/libxml2 )
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ libtirpc? ( net-libs/libtirpc:= )
+ !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+ dev-libs/openssl:=[-bindist(-)]
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/acl
+ test? ( >=dev-util/cmocka-1.0.1
+ app-benchmarks/dbench
+ dev-vcs/git
+ net-fs/nfs-utils
+ virtual/perl-Test-Harness
+ dev-libs/yajl
+ sys-fs/xfsprogs
+ sys-apps/attr )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+# if the argp.h header is found in the system. Which should be the case with
+# glibc or if argp-standalone is installed.
+
+pkg_setup() {
+ python_setup "python3*"
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # build rpc-transport and xlators only once as shared libs
+ find rpc/rpc-transport xlators -name Makefile.am -exec \
+ sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' {} + || die
+
+ # fix execution permissions
+ chmod +x libglusterfs/src/gen-defaults.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fusermount \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-client) \
+ $(use_enable georeplication) \
+ $(use_enable static-libs static) \
+ $(use_enable syslog) \
+ $(use_enable test cmocka) \
+ $(use_enable xml xml-output) \
+ $(use libtirpc || echo --without-libtirpc) \
+ $(use ipv6 && echo --with-ipv6-default) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+src_install() {
+ default
+
+ rm \
+ "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+ "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+ "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+ if use rsyslog ; then
+ insinto /etc/rsyslog.d
+ newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+
+ # insert some other tools which might be useful
+ insinto /usr/share/glusterfs/scripts
+ doins \
+ extras/backend-{cleanup,xattr-sanitize}.sh \
+ extras/clear_xattrs.sh \
+ extras/migrate-unify-to-distribute.sh
+
+ # correct permissions on installed scripts
+ # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+ chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd-r4.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+ # QA
+ rm -r "${ED}/var/run/" || die
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+
+ python_optimize "${ED}"
+}
+
+pkg_postinst() {
+ tmpfiles_process gluster.conf
+
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ echo
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ echo
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+ echo
+ elog "If you are upgrading from a previous version of ${PN}, please read:"
+ elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}