summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-02-20 09:59:55 +0800
committerSam James <sam@gentoo.org>2023-02-20 04:26:02 +0000
commit1d983277e4fcd3db3a723bf3eeba896eadd67c2c (patch)
tree03210ce30a70c72b5b6f58aa66b92a578a4d53e4
parentsys-devel/gcc: add 13.0.1_pre20230219 (diff)
downloadgentoo-1d983277e4fcd3db3a723bf3eeba896eadd67c2c.tar.gz
gentoo-1d983277e4fcd3db3a723bf3eeba896eadd67c2c.tar.bz2
gentoo-1d983277e4fcd3db3a723bf3eeba896eadd67c2c.zip
dev-util/hip: backport patch to fix gcc-13 compile issue
Closes: https://bugs.gentoo.org/895396 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/hip/files/rocclr-5.3.3-gcc13.patch25
-rw-r--r--dev-util/hip/hip-5.3.3-r3.ebuild1
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/hip/files/rocclr-5.3.3-gcc13.patch b/dev-util/hip/files/rocclr-5.3.3-gcc13.patch
new file mode 100644
index 000000000000..17a64d20bf1e
--- /dev/null
+++ b/dev-util/hip/files/rocclr-5.3.3-gcc13.patch
@@ -0,0 +1,25 @@
+From ca70cd7c3d63b1036e604116f3b269ca123e7904 Mon Sep 17 00:00:00 2001
+From: Jeremy Newton <Jeremy.Newton@amd.com>
+Date: Wed, 8 Feb 2023 14:03:58 -0500
+Subject: [PATCH] SWDEV-1 - device: Add missing include
+
+Newer GCC's seem to require this.
+
+Change-Id: I85926d4fa552b772f2eb9f8ede7863a546c47f54
+Signed-off-by: Jeremy Newton <Jeremy.Newton@amd.com>
+---
+ device/devhcprintf.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/device/devhcprintf.cpp b/device/devhcprintf.cpp
+index b36f7758..a5aba4a4 100644
+--- a/device/devhcprintf.cpp
++++ b/device/devhcprintf.cpp
+@@ -23,6 +23,7 @@
+
+ #include <assert.h>
+ #include <cstdarg>
++#include <cstdint>
+ #include <cstdio>
+ #include <cstring>
+ #include <string>
diff --git a/dev-util/hip/hip-5.3.3-r3.ebuild b/dev-util/hip/hip-5.3.3-r3.ebuild
index b4f51b3ef7b0..e73675209ae1 100644
--- a/dev-util/hip/hip-5.3.3-r3.ebuild
+++ b/dev-util/hip/hip-5.3.3-r3.ebuild
@@ -105,6 +105,7 @@ src_prepare() {
pushd ${CLR_S} || die
eapply "${FILESDIR}/rocclr-${PV}-fix-include.patch"
+ eapply "${FILESDIR}/rocclr-5.3.3-gcc13.patch"
}
src_configure() {