summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-23 19:54:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-23 19:54:26 +0300
commit1d9bfc3a809d61c360d8082d73889f42932dac26 (patch)
treef4a38741c31c25d2b7f0eff64cd2990f764b662b
parentdev-python/astroid: add 2.12.3 (diff)
downloadgentoo-1d9bfc3a.tar.gz
gentoo-1d9bfc3a.tar.bz2
gentoo-1d9bfc3a.zip
dev-python/python-cstruct: add 2.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-cstruct/Manifest1
-rw-r--r--dev-python/python-cstruct/python-cstruct-2.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 5a7d48a0dbb3..9e7cc4c9d953 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1 +1,2 @@
DIST python-cstruct-2.1.tar.gz 17298 BLAKE2B 9acc10f0d386c4413634945fc94b3e44210617c408ee18cf6533f70e7d64c609d463e9beceeea7c79b125e0bf0ab67a720d9ff98f45b4e7ce1f51d9280b55733 SHA512 c56c87d291c4aa2afcfdbcbbc19c03ec634b6fb0dcde9d516ef2a9079be2fea52a053c47cd20dfc0fe6537ac90939364da659d8eb4763069a9990681207d432c
+DIST python-cstruct-2.2.gh.tar.gz 18764 BLAKE2B 75aaffae27fef59799e52866f8169cc5d7362ef1553a56986f361ef7cfb7ca3e7d8c67fe0f112ec8e03ddacf45885e19fc1ce0d9d27c7581deafbf7e7fe1789b SHA512 5a1d62b596fef08a48020557e82fc81360430d94f18ce0667919815d57b944102067c2fe5723372616f73c995afd3a1f674e4a37e406d0dc7eeaf9fe3ef8f484
diff --git a/dev-python/python-cstruct/python-cstruct-2.2.ebuild b/dev-python/python-cstruct/python-cstruct-2.2.ebuild
new file mode 100644
index 000000000000..7b8d01c50942
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct
+ https://pypi.org/project/cstruct/"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "/find_packages(/s@exclude=\[@&'tests', @" -i setup.py || die
+}