summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-08-22 13:09:48 -0400
committerMike Gilbert <floppym@gentoo.org>2015-08-22 13:16:24 -0400
commit1dbc772ea5dbbac9a8f910033d0fb5abd7b45459 (patch)
tree171bf799ec0a6a6b94272dc4e262092f10ab049b
parentkde-misc/kde-gtk-config: backport patch from upstream fixing build with kde-b... (diff)
downloadgentoo-1dbc772ea5dbbac9a8f910033d0fb5abd7b45459.tar.gz
gentoo-1dbc772ea5dbbac9a8f910033d0fb5abd7b45459.tar.bz2
gentoo-1dbc772ea5dbbac9a8f910033d0fb5abd7b45459.zip
sys-apps/systemd: Backport build fix for alpha
Bug: https://bugs.gentoo.org/543900 Package-Manager: portage-2.2.20_p134
-rw-r--r--sys-apps/systemd/files/224-0002-Use-getxpid-syscall-on-alpha-for-raw_getpid.patch30
-rw-r--r--sys-apps/systemd/systemd-224-r1.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/systemd/files/224-0002-Use-getxpid-syscall-on-alpha-for-raw_getpid.patch b/sys-apps/systemd/files/224-0002-Use-getxpid-syscall-on-alpha-for-raw_getpid.patch
new file mode 100644
index 000000000000..40e2d1c15e12
--- /dev/null
+++ b/sys-apps/systemd/files/224-0002-Use-getxpid-syscall-on-alpha-for-raw_getpid.patch
@@ -0,0 +1,30 @@
+From a242a99d42276b6b764f80bd0de70c26e5c5f1d4 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Tue, 4 Aug 2015 14:47:01 -0700
+Subject: [PATCH] Use getxpid syscall on alpha for raw_getpid()
+
+Alpha does not have a getpid syscall, but rather has getxpid to match
+OSF/1.
+---
+ src/basic/missing.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/basic/missing.h b/src/basic/missing.h
+index ed6cd80..34ab025 100644
+--- a/src/basic/missing.h
++++ b/src/basic/missing.h
+@@ -977,7 +977,11 @@ static inline int raw_clone(unsigned long flags, void *child_stack) {
+ }
+
+ static inline pid_t raw_getpid(void) {
++#if defined(__alpha__)
++ return (pid_t) syscall(__NR_getxpid);
++#else
+ return (pid_t) syscall(__NR_getpid);
++#endif
+ }
+
+ #if !HAVE_DECL_RENAMEAT2
+--
+2.5.0
+
diff --git a/sys-apps/systemd/systemd-224-r1.ebuild b/sys-apps/systemd/systemd-224-r1.ebuild
index 7d4b2b79fa97..521109e8dc22 100644
--- a/sys-apps/systemd/systemd-224-r1.ebuild
+++ b/sys-apps/systemd/systemd-224-r1.ebuild
@@ -105,6 +105,7 @@ fi
PATCHES=(
"${FILESDIR}/218-Dont-enable-audit-by-default.patch"
"${FILESDIR}/224-0001-networkd-fix-neworkd-crash.patch"
+ "${FILESDIR}/224-0002-Use-getxpid-syscall-on-alpha-for-raw_getpid.patch"
)
pkg_pretend() {