summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-13 11:18:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-13 11:18:24 +0100
commit1df4f7998a84657aeb071bee1f4a6daeda4f0a22 (patch)
tree811144b88f27edfdac97ffeb2927fc4c14f8c576
parentsys-apps/sandbox: Version bump (diff)
downloadgentoo-1df4f799.tar.gz
gentoo-1df4f799.tar.bz2
gentoo-1df4f799.zip
kde-frameworks/plasma: Add fix for Plasma crash
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--kde-frameworks/plasma/files/plasma-5.56.0-crashfix.patch40
-rw-r--r--kde-frameworks/plasma/plasma-5.56.0-r1.ebuild73
2 files changed, 113 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.56.0-crashfix.patch b/kde-frameworks/plasma/files/plasma-5.56.0-crashfix.patch
new file mode 100644
index 000000000000..844ddf6a234d
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.56.0-crashfix.patch
@@ -0,0 +1,40 @@
+From ebae2d63033647950cf0f9d97410723a8c7db1f3 Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Tue, 12 Mar 2019 07:03:10 +0100
+Subject: Remove crash in plasmashell
+
+Summary: remove bug in plasmashell Bug 405341
+
+Test Plan: can't reproduce bug
+
+Reviewers: dfaure, #frameworks, #plasma, broulik
+
+Reviewed By: #plasma, broulik
+
+Subscribers: broulik, kde-frameworks-devel
+
+Tags: #frameworks
+
+Differential Revision: https://phabricator.kde.org/D19698
+---
+ src/declarativeimports/core/datamodel.cpp | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/declarativeimports/core/datamodel.cpp b/src/declarativeimports/core/datamodel.cpp
+index 50dc6c5..03bea20 100644
+--- a/src/declarativeimports/core/datamodel.cpp
++++ b/src/declarativeimports/core/datamodel.cpp
+@@ -64,7 +64,10 @@ void SortFilterModel::syncRoleNames()
+
+ QHash<int,QByteArray> SortFilterModel::roleNames() const
+ {
+- return sourceModel()->roleNames();
++ if (sourceModel()) {
++ return sourceModel()->roleNames();
++ }
++ return {};
+ }
+
+ int SortFilterModel::roleNameToId(const QString &name) const
+--
+cgit v1.1
diff --git a/kde-frameworks/plasma/plasma-5.56.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.56.0-r1.ebuild
new file mode 100644
index 000000000000..fce285228be2
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.56.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="${PN}-framework"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma framework"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 wayland X"
+
+BDEPEND="
+ $(add_frameworks_dep kdoctools)
+"
+RDEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kirigami)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui 'gles2=')
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ !gles2? ( virtual/opengl )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package !gles2 OpenGL)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}