summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-03 08:33:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-03 10:07:57 +0300
commit1e1706c3e7d08eb90ff7786b04a64d05cb328935 (patch)
treec11370a08a26af0c05498c238acfb68ea7483142
parentapp-misc/fastfetch: drop 2.11.0 (diff)
downloadgentoo-1e1706c3e7d08eb90ff7786b04a64d05cb328935.tar.gz
gentoo-1e1706c3e7d08eb90ff7786b04a64d05cb328935.tar.bz2
gentoo-1e1706c3e7d08eb90ff7786b04a64d05cb328935.zip
dev-python/agate: add 1.10.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.10.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index 2d7ff2d25d11..444e93cf4111 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1 +1,2 @@
DIST agate-1.10.1.tar.gz 203139 BLAKE2B 656cc5f9abcc38848560bb81a9e7b1a8cf498897ea49a98bd3b44f3d625c69047ef3fa32b4a7191d8807c1bee29bd0c5a8d0ed99e1b91e30ea294b8fb436fb3d SHA512 b039fa587d1fc49277860f9876ad1f885f2530e82888ad8a32066f35e3086b5da0cb7aa9a2ed09ea7992efe649d32df27a372f85e4a06e8aca0d6ec8651567b5
+DIST agate-1.10.2.tar.gz 203542 BLAKE2B 697aa898756ab256ed8e9bb92a29b3ad1f8edeb7a8b9636d753a74373714d84a6d0a5d4abb8600b52eb510e478f16ca707839a01ab3a05fec72d88e443322dae SHA512 87385515e3ffe88afdeaa1202368d69824501dc5816b40e1f475afd027bbd5229c70e7449485e0845f50203e6749f3a736d16f17752d1bdd040dc92cbcc2461a
diff --git a/dev-python/agate/agate-1.10.2.ebuild b/dev-python/agate/agate-1.10.2.ebuild
new file mode 100644
index 000000000000..baca934b9901
--- /dev/null
+++ b/dev-python/agate/agate-1.10.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cssselect-0.9.1[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)