summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-12 18:15:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-12 18:15:23 +0200
commit1e1aa3d7218f7e7b850893049f6bc704105a1181 (patch)
tree0c4460b337ff54b56196d53356749d23dea9dbba
parentdev-python/cattrs: Add a patch to fix tests on 32-bit systems (diff)
downloadgentoo-1e1aa3d7218f7e7b850893049f6bc704105a1181.tar.gz
gentoo-1e1aa3d7218f7e7b850893049f6bc704105a1181.tar.bz2
gentoo-1e1aa3d7218f7e7b850893049f6bc704105a1181.zip
dev-python/h5py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/h5py/Manifest1
-rw-r--r--dev-python/h5py/files/h5py-3.8.0-cython3.patch26
-rw-r--r--dev-python/h5py/h5py-3.8.0.ebuild74
3 files changed, 0 insertions, 101 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index cac65c4a1f7a..438d98fcb61c 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,2 +1 @@
-DIST h5py-3.8.0.tar.gz 400774 BLAKE2B 2e48991225170fbb728fa55a68aea795db42c7eae605d123a24a59a8730220ddc98e88dfbff60220ce8c6952ca7fc0c3e33d472acae09864a29bfe11d90fcca1 SHA512 13397f66a9fc735e1143eb9e3dd584280e955adf49de467bf56c1a98952903720480ab8d505921b7e22c16453498625ad93421a64e520f15ea3566472849a8fd
DIST h5py-3.9.0.tar.gz 402856 BLAKE2B e2c617c492c2fba751fa546292232b78e1cec4bc75fb50a7c59cdb4a34bc927134d4604d3d9b24f880235cfb356636e66907b8026107547905a77ed9732ccc26 SHA512 f87cb36ba874e86b179776031c3345ad83bc7b5eff2f3ee54acb6b0997cc7925c17dc478957103ab6bb07d8aaa8593af1d51c3547021a205e9d01c0e36d833a9
diff --git a/dev-python/h5py/files/h5py-3.8.0-cython3.patch b/dev-python/h5py/files/h5py-3.8.0-cython3.patch
deleted file mode 100644
index 3201a2ea0e6b..000000000000
--- a/dev-python/h5py/files/h5py-3.8.0-cython3.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From af48a740070643549e76890fcc88276fe4ee1159 Mon Sep 17 00:00:00 2001
-From: Thomas A Caswell <tcaswell@bnl.gov>
-Date: Mon, 3 Apr 2023 14:55:18 -0400
-Subject: [PATCH] BLD: fix for cython3 compatibility
-
----
- h5py/_errors.pyx | 2 +-
- pyproject.toml | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/h5py/_errors.pyx b/h5py/_errors.pyx
-index ca7b1c48..c3bd184e 100644
---- a/h5py/_errors.pyx
-+++ b/h5py/_errors.pyx
-@@ -94,7 +94,7 @@ cdef struct err_data_t:
- H5E_error_t err
- int n
-
--cdef herr_t walk_cb(unsigned int n, const H5E_error_t *desc, void *e) nogil:
-+cdef herr_t walk_cb(unsigned int n, const H5E_error_t *desc, void *e) nogil noexcept:
-
- cdef err_data_t *ee = <err_data_t*>e
-
---
-2.40.1
-
diff --git a/dev-python/h5py/h5py-3.8.0.ebuild b/dev-python/h5py/h5py-3.8.0.ebuild
deleted file mode 100644
index 6af255d496d6..000000000000
--- a/dev-python/h5py/h5py-3.8.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="
- https://www.h5py.org/
- https://github.com/h5py/h5py/
- https://pypi.org/project/h5py/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-# disable mpi until mpi4py gets python3_8
-#IUSE="examples mpi"
-IUSE="examples"
-
-#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
-DEPEND="
- sci-libs/hdf5:=[hl(+)]
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/QtPy[testlib,${PYTHON_USEDEP}]
- )
-"
-# mpi? ( virtual/mpi )
-# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-#pkg_setup() {
-# use mpi && export CC=mpicc
-#}
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${P}-cython3.patch"
- )
-
- # avoid pytest-mpi dep, we do not use mpi anyway
- sed -i -e 's:pytest-mpi::' pytest.ini || die
- distutils-r1_python_prepare_all
-
- export H5PY_SETUP_REQUIRES=0
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- epytest -m "not mpi"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}