summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-01-26 15:52:31 -0800
committerPatrick McLean <chutzpah@gentoo.org>2018-01-26 15:52:52 -0800
commit1e45f7cd1dfa04ef4b89eb453df04b62ee432425 (patch)
tree0ce2cf91cbcf58c8405f04107a58876abca0e31c
parentprofiles/updates/1Q-2016: drop obsolete entries (diff)
downloadgentoo-1e45f7cd.tar.gz
gentoo-1e45f7cd.tar.bz2
gentoo-1e45f7cd.zip
media-libs/glm: Add patch to support gcc-7.3 to 0.9.8.5
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--media-libs/glm/files/glm-gcc73.patch35
-rw-r--r--media-libs/glm/glm-0.9.8.5.ebuild6
2 files changed, 40 insertions, 1 deletions
diff --git a/media-libs/glm/files/glm-gcc73.patch b/media-libs/glm/files/glm-gcc73.patch
new file mode 100644
index 000000000000..68033b5b6f63
--- /dev/null
+++ b/media-libs/glm/files/glm-gcc73.patch
@@ -0,0 +1,35 @@
+diff -ur glm-0.9.8.5.orig/glm/simd/platform.h glm-0.9.8.5/glm/simd/platform.h
+--- glm-0.9.8.5.orig/glm/simd/platform.h 2017-08-16 05:15:24.000000000 -0700
++++ glm-0.9.8.5/glm/simd/platform.h 2018-01-26 15:38:57.584130263 -0800
+@@ -111,7 +111,8 @@
+ #define GLM_COMPILER_GCC70 0x02000A00
+ #define GLM_COMPILER_GCC71 0x02000B00
+ #define GLM_COMPILER_GCC72 0x02000C00
+-#define GLM_COMPILER_GCC80 0x02000D00
++#define GLM_COMPILER_GCC73 0x02000D00
++#define GLM_COMPILER_GCC80 0x02000E00
+
+ // CUDA
+ #define GLM_COMPILER_CUDA 0x10000000
+@@ -283,6 +284,8 @@
+ # define GLM_COMPILER (GLM_COMPILER_GCC71)
+ # elif (__GNUC__ == 7) && (__GNUC_MINOR__ == 2)
+ # define GLM_COMPILER (GLM_COMPILER_GCC72)
++# elif (__GNUC__ == 7) && (__GNUC_MINOR__ == 3)
++# define GLM_COMPILER (GLM_COMPILER_GCC73)
+ # elif (__GNUC__ >= 8)
+ # define GLM_COMPILER (GLM_COMPILER_GCC80)
+ # else
+diff -ur glm-0.9.8.5.orig/test/core/core_setup_message.cpp glm-0.9.8.5/test/core/core_setup_message.cpp
+--- glm-0.9.8.5.orig/test/core/core_setup_message.cpp 2017-08-16 05:15:24.000000000 -0700
++++ glm-0.9.8.5/test/core/core_setup_message.cpp 2018-01-26 15:37:56.953298475 -0800
+@@ -86,6 +86,9 @@
+ case GLM_COMPILER_GCC72:
+ std::printf("GCC 7.2\n");
+ break;
++ case GLM_COMPILER_GCC73:
++ std::printf("GCC 7.3\n");
++ break;
+ case GLM_COMPILER_GCC80:
+ std::printf("GCC 8.0\n");
+ break;
diff --git a/media-libs/glm/glm-0.9.8.5.ebuild b/media-libs/glm/glm-0.9.8.5.ebuild
index 548d897c6840..073f3bee1e27 100644
--- a/media-libs/glm/glm-0.9.8.5.ebuild
+++ b/media-libs/glm/glm-0.9.8.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,10 @@ IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86
RDEPEND="virtual/opengl"
+PATCHES=(
+ "${FILESDIR}/glm-gcc73.patch"
+)
+
src_configure() {
if use test; then
local mycmakeargs=(