summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-21 13:55:19 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-21 14:05:42 -0400
commit1e627a3d4797680ed8023d81fe122ffbff26bc62 (patch)
treee2c0c1b73b0c0bd93b29d8d010d9f47096c4962b
parentdev-cpp/simpleini: install cmake config files (diff)
downloadgentoo-1e627a3d4797680ed8023d81fe122ffbff26bc62.tar.gz
gentoo-1e627a3d4797680ed8023d81fe122ffbff26bc62.tar.bz2
gentoo-1e627a3d4797680ed8023d81fe122ffbff26bc62.zip
dev-cpp/simpleini: tidy a bit
- scrub patches - pkgconfig patch is obsolete, does not matter with cmake - can skip pkgconfig dep, always provided with cmake Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-cpp/simpleini/files/simpleini-4.22-disable-tests.patch13
-rw-r--r--dev-cpp/simpleini/files/simpleini-4.22-include-dir.patch13
-rw-r--r--dev-cpp/simpleini/simpleini-4.22-r1.ebuild5
3 files changed, 6 insertions, 25 deletions
diff --git a/dev-cpp/simpleini/files/simpleini-4.22-disable-tests.patch b/dev-cpp/simpleini/files/simpleini-4.22-disable-tests.patch
index 380c50d587e7..39347e75f769 100644
--- a/dev-cpp/simpleini/files/simpleini-4.22-disable-tests.patch
+++ b/dev-cpp/simpleini/files/simpleini-4.22-disable-tests.patch
@@ -1,14 +1,8 @@
-From f7862c3dd7ad35becc2741f268e3402e89a37666 Mon Sep 17 00:00:00 2001
+https://github.com/brofield/simpleini/pull/75
+https://github.com/brofield/simpleini/commit/f7862c3dd7ad35becc2741f268e3402e89a37666
From: Alexandre Bouvier <contact@amb.tf>
Date: Tue, 2 Jan 2024 10:54:44 +0100
Subject: [PATCH 2/2] cmake: really disable tests (#75)
-
----
- CMakeLists.txt | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7804947..4b360ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,5 +72,7 @@ target_include_directories(${PROJECT_NAME} INTERFACE
@@ -20,6 +14,3 @@ index 7804947..4b360ad 100644
+ add_subdirectory(tests)
+ endif()
endif()
---
-2.43.2
-
diff --git a/dev-cpp/simpleini/files/simpleini-4.22-include-dir.patch b/dev-cpp/simpleini/files/simpleini-4.22-include-dir.patch
index 78fba987bc0a..7370ae04b8b2 100644
--- a/dev-cpp/simpleini/files/simpleini-4.22-include-dir.patch
+++ b/dev-cpp/simpleini/files/simpleini-4.22-include-dir.patch
@@ -1,14 +1,8 @@
-From aeacf861a8ad8add5f4974792a88ffea393e41db Mon Sep 17 00:00:00 2001
+https://github.com/brofield/simpleini/pull/74
+https://github.com/brofield/simpleini/commit/aeacf861a8ad8add5f4974792a88ffea393e41db
From: Alexandre Bouvier <contact@amb.tf>
Date: Tue, 2 Jan 2024 08:42:03 +0100
Subject: [PATCH 1/2] cmake: fix namespace and include dir (#74)
-
----
- CMakeLists.txt | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8f09295..7804947 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,7 @@ configure_package_config_file(${PROJECT_NAME}Config.cmake.in
@@ -39,6 +33,3 @@ index 8f09295..7804947 100644
+ include(CTest)
add_subdirectory(tests)
endif()
---
-2.43.2
-
diff --git a/dev-cpp/simpleini/simpleini-4.22-r1.ebuild b/dev-cpp/simpleini/simpleini-4.22-r1.ebuild
index e5b4c147bbb9..e584cfbdc410 100644
--- a/dev-cpp/simpleini/simpleini-4.22-r1.ebuild
+++ b/dev-cpp/simpleini/simpleini-4.22-r1.ebuild
@@ -16,10 +16,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="test? ( dev-cpp/gtest )"
-BDEPEND="test? ( virtual/pkgconfig )"
PATCHES=(
- "${FILESDIR}"/${PN}-4.20-pkgconfig-var.patch
"${FILESDIR}"/${P}-include-dir.patch
"${FILESDIR}"/${P}-disable-tests.patch
)
@@ -27,7 +25,8 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
- -DSIMPLEINI_USE_SYSTEM_GTEST=ON
+ -DSIMPLEINI_USE_SYSTEM_GTEST=yes
)
+
cmake_src_configure
}