summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-08 17:19:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-08 17:19:23 +0100
commit1e698bc6d1e4db57f8c3555cdb5b72f45db3b9a7 (patch)
tree9addf5bc65130246eb749a89e2f7609939474719
parentdev-ros/rospy: Add python 3.5 support (diff)
downloadgentoo-1e698bc6d1e4db57f8c3555cdb5b72f45db3b9a7.tar.gz
gentoo-1e698bc6d1e4db57f8c3555cdb5b72f45db3b9a7.tar.bz2
gentoo-1e698bc6d1e4db57f8c3555cdb5b72f45db3b9a7.zip
dev-ros/depthimage_to_laserscan: Fix build with gcc 5, bug #608474
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r1.ebuild3
-rw-r--r--dev-ros/depthimage_to_laserscan/files/isnan.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r1.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r1.ebuild
index 18325b46052b..69d11c294c60 100644
--- a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r1.ebuild
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,3 +23,4 @@ RDEPEND="
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/files/isnan.patch b/dev-ros/depthimage_to_laserscan/files/isnan.patch
new file mode 100644
index 000000000000..11254904e945
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/files/isnan.patch
@@ -0,0 +1,13 @@
+Index: depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScan.cpp
+===================================================================
+--- depthimage_to_laserscan-1.0.7.orig/src/DepthImageToLaserScan.cpp
++++ depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScan.cpp
+@@ -59,7 +59,7 @@ bool DepthImageToLaserScan::use_point(co
+
+ // Infs are preferable over NaNs (more information)
+ if(!new_finite && !old_finite){ // Both are not NaN or Inf.
+- if(!isnan(new_value)){ // new is not NaN, so use it's +-Inf value.
++ if(!std::isnan(new_value)){ // new is not NaN, so use it's +-Inf value.
+ return true;
+ }
+ return false; // Do not replace old_value