summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-09 10:42:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-09 11:30:08 +0200
commit1e840fc19bec5b80348d3160e29d4455b15cdc6b (patch)
treed19bdfc819cc4bb38fae52503b538c070f4fb3a8
parentapp-emulation/uxn: drop old 0_p20230803 (diff)
downloadgentoo-1e840fc19bec5b80348d3160e29d4455b15cdc6b.tar.gz
gentoo-1e840fc19bec5b80348d3160e29d4455b15cdc6b.tar.bz2
gentoo-1e840fc19bec5b80348d3160e29d4455b15cdc6b.zip
sci-electronics/nvc: drop old 1.11.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-electronics/nvc/Manifest1
-rw-r--r--sci-electronics/nvc/nvc-1.11.2.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/sci-electronics/nvc/Manifest b/sci-electronics/nvc/Manifest
index 739f6012d537..1e66ebcb7f1e 100644
--- a/sci-electronics/nvc/Manifest
+++ b/sci-electronics/nvc/Manifest
@@ -1,2 +1 @@
-DIST nvc-1.11.2.tar.gz 1842005 BLAKE2B e2d616f70088cfead82931f27ff346e0343b53181c1cd1257ae38790146a0927b5a650e575a91191174c472f2d877cfe596aad879f9af0c043361eb286846648 SHA512 a129ec6a845e956cc55b2158bb8913eedd0b5a3b866726992f2d249d29b268287b60a3e2a74709d146e2bc68696f6bd3db4f1a2003c78a161037d2ae12cfa3d5
DIST nvc-1.11.3.tar.gz 1843551 BLAKE2B 27cf3a6cfa0b21ca0ff9f2f96a150fea2a3d55a53969228d6d83475458e5a1c6ef76a676afc73588a5de2acaaf2ec40d04a5c8296ec6615501572e3c6903d9f8 SHA512 22e5e6daad4d79822e7d1eac02c095f24a23e7237e8e8af9e085f225edf7dbf0c557fefb8d50ca20ccd14d9e3dd20b7d01b7363a651ab088685d1737fbe03ccd
diff --git a/sci-electronics/nvc/nvc-1.11.2.ebuild b/sci-electronics/nvc/nvc-1.11.2.ebuild
deleted file mode 100644
index 5ed8a314d8ca..000000000000
--- a/sci-electronics/nvc/nvc-1.11.2.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_MAX_SLOT=16
-
-inherit autotools bash-completion-r1 llvm
-
-DESCRIPTION="NVC is a VHDL compiler and simulator"
-HOMEPAGE="https://www.nickg.me.uk/nvc/
- https://github.com/nickg/nvc/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/nickg/nvc.git"
-
- NVC_SOURCEDIR="${WORKDIR}"/${PN}-${PV}
-else
- SRC_URI="https://github.com/nickg/nvc/archive/r${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-
- NVC_SOURCEDIR="${WORKDIR}"/${PN}-r${PV}
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="debug llvm"
-RESTRICT="test" # Some tests fail.
-
-RDEPEND="
- app-arch/bzip2:=
- app-arch/zstd:=
- dev-libs/capstone:=
- dev-libs/elfutils
- dev-libs/icu:=
- dev-libs/libffi:=
- dev-libs/libxml2:=
- sys-libs/ncurses:=
- sys-libs/zlib:=
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-libs/check
- sys-devel/bison
- sys-devel/flex
-"
-
-NVC_BUILDDIR="${NVC_SOURCEDIR}_BuildDir"
-S="${NVC_BUILDDIR}"
-
-PATCHES=( "${FILESDIR}/nvc-1.9.2-jit-code-capstone.patch" )
-
-# Special libraries for NVC.
-QA_FLAGS_IGNORED="usr/lib[0-9]*/nvc/preload[0-9]*.so"
-
-pkg_setup() {
- use llvm && llvm_pkg_setup
-}
-
-src_unpack() {
- default
-
- mkdir -p "${S}" || die
-}
-
-src_prepare() {
- pushd "${NVC_SOURCEDIR}" >/dev/null || die
-
- default
- eautoreconf
-
- popd >/dev/null || die
-}
-
-src_configure() {
- # Needs "bison" and "flex" exactly.
- unset LEX
- unset YACC
-
- local ECONF_SOURCE="${NVC_SOURCEDIR}"
- local -a myconf=(
- --enable-verilog
- --enable-vital
- --with-bash-completion="$(get_bashcompdir)"
- $(use_enable debug)
- $(use_enable llvm)
- )
- econf "${myconf[@]}"
-
- export V=1 # Verbose compilation and install.
-}
-
-src_compile() {
- emake -j1
-}
-
-src_test() {
- PATH="${S}/bin:${PATH}" emake check
-}
-
-src_install() {
- default
-
- mv "${D}/$(get_bashcompdir)"/nvc{.bash,} || die
-
- dostrip -x "/usr/$(get_libdir)/nvc"
-}