summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-10-29 00:51:51 +0100
committerMatthew Smith <matthew@gentoo.org>2022-11-04 17:12:13 +0000
commit1ec2683c951a9905c8a139410dc2da9dd1548b4e (patch)
treec9fcbffa1de14f13d2d6aa3d8fadc63a9e159fc4
parentnet-mail/getmail: add 6.18.10 (diff)
downloadgentoo-1ec2683c.tar.gz
gentoo-1ec2683c.tar.bz2
gentoo-1ec2683c.zip
media-sound/scream: add 4.0
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--media-sound/scream/Manifest1
-rw-r--r--media-sound/scream/scream-4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/scream/Manifest b/media-sound/scream/Manifest
index 99e80ea18113..a8be72170876 100644
--- a/media-sound/scream/Manifest
+++ b/media-sound/scream/Manifest
@@ -1 +1,2 @@
DIST scream-3.9.tar.gz 1114518 BLAKE2B f7ae8ca69bc786fdb8055b2d1d5cd8fb9350c147465e1d75936defba8ea630351b4a559e508ef3b1f3bbd24d9b2bf96b6450577c7e5e334aacfd54f71efc5928 SHA512 83cb5b9daca82395b955fc8e01be4a466c6ebcc3839179c47912a78294ca98abed3833b6c636632a37e9d944750f56680a2a55975376756d183c9ed9b1d3dede
+DIST scream-4.0.tar.gz 1114738 BLAKE2B 8e67033faea465d6d64427c9c7ff40d38ad88892cbcb9d3fa3d09998161fef2fce998a6d11e5c416f8b5652701f6c9dcf86283e44e084e7fa005aaf8275b49c6 SHA512 70b41f946e5f3dc3ccdceef752a719ba59841a850a9b347e8d33dc08dd5c3a4ba3d2fe5ae5004b9b621372f5d3faf52b34dc02fdaaa5be6f89991084425f682a
diff --git a/media-sound/scream/scream-4.0.ebuild b/media-sound/scream/scream-4.0.ebuild
new file mode 100644
index 000000000000..8c7ed7611cf1
--- /dev/null
+++ b/media-sound/scream/scream-4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
+HOMEPAGE="https://github.com/duncanthrax/scream"
+S="${WORKDIR}/${P}/Receivers/unix"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
+else
+ SRC_URI="https://github.com/duncanthrax/scream/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Ms-PL"
+SLOT="0"
+IUSE="alsa jack pcap pulseaudio"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ jack? (
+ media-libs/soxr
+ virtual/jack
+ )
+ pcap? ( net-libs/libpcap )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DALSA_ENABLE=$(usex alsa)
+ -DJACK_ENABLE=$(usex jack)
+ -DPCAP_ENABLE=$(usex pcap)
+ -DPULSEAUDIO_ENABLE=$(usex pulseaudio)
+ )
+ cmake_src_configure
+}