summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-01 09:30:35 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-02 07:31:50 +0100
commit1eca0a0d8bfcbc92a2a480bf783316a81554f93c (patch)
treea60c4f65d7928ffe3539809f1b38f659b33ca787
parentdev-ruby/faraday: add ruby27 (diff)
downloadgentoo-1eca0a0d.tar.gz
gentoo-1eca0a0d.tar.bz2
gentoo-1eca0a0d.zip
dev-ruby/jwt: add ruby27
Also add missing test dependency on rbnacl. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/jwt/jwt-2.2.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ruby/jwt/jwt-2.2.1.ebuild b/dev-ruby/jwt/jwt-2.2.1.ebuild
index 297c32535e27..1f2bda08e687 100644
--- a/dev-ruby/jwt/jwt-2.2.1.ebuild
+++ b/dev-ruby/jwt/jwt-2.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby25 ruby26"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -23,6 +23,8 @@ IUSE=""
RUBY_S="ruby-jwt-${PV}"
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
all_ruby_prepare() {
sed -i -e "/simplecov/ s:^:#:" \
-e '/^SimpleCov.configure/,/^end/ s:^:#:' \