summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-14 23:07:47 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-14 23:07:59 +0100
commit1ed2a12d336ac185e3fcf6b12704dfbafc66d2f1 (patch)
treeb0bbcbd0698ad6d6e431fee4e47b19e532965bb6
parentnet-fs/samba: stable 4.5.16 for sparc, bug #650382 (diff)
downloadgentoo-1ed2a12d.tar.gz
gentoo-1ed2a12d.tar.bz2
gentoo-1ed2a12d.zip
dev-python/brython: version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 345283e89fee..599ef0fcb217 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,3 +1,4 @@
DIST brython-3.3.3.zip 10040987 BLAKE2B a6a238ac6189e9170653c1987db46f2e0735f25deccaf0318ebc669b48dce1330acf333ef27300f1061e7e18044cfa24fadc02265d0fe3a83d0aa8b97f4de684 SHA512 e182a6c859cd18b90b205f751260b0b5c8d250746e48844c59cd61608dfdaf0fd6f0f25b8061de9505b7c5d094ac68fe57536c52cb31adb48f04c2cc5624e249
DIST brython-3.3.4.zip 10047374 BLAKE2B ba4719476206fd71f412d646deb6a7eea3a0aef930814d7fa3589a3e736818f2bc7edf7f642998ae1471da87e3ad05ce89fd9dd32d569267ba45174543e4e520 SHA512 818181e040eefaeffd1e8866af471626ff5874fd99c3ee9fcc09c46a4b4b836619045a2712a8e16121a1132c86407b0676a8125e707eff4c7e867851cf20cecd
DIST brython-3.3.5.tar.gz 9215864 BLAKE2B 985671d9d60396101b01813b151798d57ca8b7e6450c9a0eae2f14e65cf06cd12e416715219128ac17ff8fa66f1aa3e736dcbfb17537140b7373598d4c873eb1 SHA512 5226d01e4d0f824885329403e2d9b80dd0bec3ed456102f54fcb3900ff08508e3268111b51b892687db21f2936d4feb4bfd328775812206790bcccb4d9e366a8
+DIST brython-3.4.0.tar.gz 9303732 BLAKE2B 18ef80ce4390f052b6743a545236f57339378ebb3df5e51cf56385fc6c25e43a8e40fe4887d86d8390475c3e02e148188c9be1622fbda4938031559a3fb72bf1 SHA512 4533dd07293efd96b8e6d8f690decb65bbe6c511654f2872b4751e549e4fae0bd48ac80f80983d1b5c7ec029b8df455dec83ba544286dd84c64124d55fdd68e1
diff --git a/dev-python/brython/brython-3.4.0.ebuild b/dev-python/brython/brython-3.4.0.ebuild
new file mode 100644
index 000000000000..50f67db89823
--- /dev/null
+++ b/dev-python/brython/brython-3.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}