summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-21 13:43:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-21 13:46:24 +0100
commit1ee0518e12f97435047a7f9f601dc7dc1dae8676 (patch)
tree21430ced863016d2efbf05dfd53f84f3f6fbe637
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-1ee0518e12f97435047a7f9f601dc7dc1dae8676.tar.gz
gentoo-1ee0518e12f97435047a7f9f601dc7dc1dae8676.tar.bz2
gentoo-1ee0518e12f97435047a7f9f601dc7dc1dae8676.zip
dev-python/python-utils: Bump to 2.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-2.5.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index a3c4462082c4..2ad81c552c1a 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,3 +1,4 @@
DIST python-utils-2.3.0.tar.gz 19384 BLAKE2B 1746deadc8dbaf49a6499fe9c79d25c2b5cfea68e2d1b7ab6f88aa72807eedcdb338058e24a7822c6360dea36f1a044145572443c57f43f4cfed765a76e48f0b SHA512 482ccf9c635a0cbe603b69488a364d9033f8b7fada279d901725b5bf91ac13b1cd4a6b7e8d5834a9355d97d8b0803397d5e13da2b7ba72f8d8e2f7f39fee027a
DIST python-utils-2.4.0.tar.gz 22230 BLAKE2B 1c144f62a009a2470ec43341283048842cba61f1b677e8b1d197d3ef39dd1d890b364e63ed8da0b30ad5560d335ab0eb2dfc329ff6dfea86c0f64e909de730b9 SHA512 bfad0ef30383df634b89bb2206a00e45434eff9fee9ba0eeab99361bacfb56f3fb420019608b639713a7e8777870de75becb1d7b48aa09c582df27f9ebe8c512
DIST python-utils-2.5.1.tar.gz 115307 BLAKE2B 2938b9f188c92d407baf09147338ea2c54b9c70c5a8746f14cd4d4b5026e6bd7bab418c9cde6c99ae4c4072da6967033bf59ed32acb0e21bfb5aacff8640620e SHA512 886ed6c1c7027012c1e5a59dfe3f81ac2b07974cc5869b5cb8f5fc91f8ca733acf0ee03dbb559be69a389228974d713666ced950ec766117075aa5ea781216fb
+DIST python-utils-2.5.2.tar.gz 14034 BLAKE2B 1d9ec9ba84ee1ebff2c4ef915bb0e57c34185c0577252f8b4cc9678f2e5b6e5a815f7c049c2f512d2f79aa8be855870ff21ec2291b1305bf8a369614220bc582 SHA512 5bcf4f33eac88b83e0cccf6b50162a5c913d9e72c4395b2265017cda566c91fa36c24eb5c3d23269b71330df65ac14226834d7b339b5b767afad3177734b9934
diff --git a/dev-python/python-utils/python-utils-2.5.2.ebuild b/dev-python/python-utils/python-utils-2.5.2.ebuild
new file mode 100644
index 000000000000..b83efbe8075e
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}