summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 14:55:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 14:55:16 +0200
commit1ee3e3a3c5124ffe2910c542ba55588df22d3982 (patch)
tree4033de4c3553a42c11052c5b110c61488433cad0
parentdev-python/boto3: Remove old (diff)
downloadgentoo-1ee3e3a3.tar.gz
gentoo-1ee3e3a3.tar.bz2
gentoo-1ee3e3a3.zip
dev-python/botocore: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest3
-rw-r--r--dev-python/botocore/botocore-1.26.5.ebuild70
-rw-r--r--dev-python/botocore/botocore-1.27.0.ebuild70
-rw-r--r--dev-python/botocore/botocore-1.27.1.ebuild70
4 files changed, 0 insertions, 213 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4dea49fd32f3..45afdb0bec33 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,5 +1,2 @@
DIST botocore-1.26.10.tar.gz 9008316 BLAKE2B a05078ec5732015cbd8ea4da2d2d82e28f4241b7c3164f3410ae396a19f79c116f7a9059a3361e99eacc952f860a516b187375dbf64ee5e4e5648e8c3b0f95a5 SHA512 b12e9002dc8e0912a9681938f343b51d628f0b2798693dc81636fe7ede01d006d5bc8a901f92edf10a88d97c3c6311aaf97206a6f55070e645747536fe39b144
-DIST botocore-1.26.5.tar.gz 8994964 BLAKE2B 472bc20b1a579674b97fa42f5b7bba2f06f1bcc40b11d5d5fa31b283a1d8648be82db4ee7e7170097d2e695bad2d1f9e398dfa7e4b85381134f151010f212be2 SHA512 a696c241989f6754596f69577c4e4f5d92df87e9b6488533e930b28b85e02fae8af1ac73d907790a75496a46824b45beb7df220c72be3bfc0bee8153b4846939
-DIST botocore-1.27.0.tar.gz 9013575 BLAKE2B e00cf7d071bc510a96e32bbc41bb0b3a151974c0c10ada01fc8222d261e680b938f248ffddd5985c8ff92bb3a4a8021a6e3867870d5411cd9ba8544b12f41dfc SHA512 386128c57a584cd6b8d51ff46817678e18292cef3f22194c64abfa007418b9ef906e85d0c0f731e0e8efc8e6a01aa71ba9230c94f86c6d0c248d385a1f79e5d9
-DIST botocore-1.27.1.tar.gz 9020507 BLAKE2B 5339a41c163f222c93fdd4232a47d98a74470ad7646e35c747517433b63c2c46c7c2d71778993d85bb4a1d5accff7d60546fb8a9cb7d60b532a8ed3dc54c8200 SHA512 685cebea8633ae996a8aa9410bdb76fd814b9bed3168aa8015ee1046f165203cf496d01b058ff5a07cbde2a9ff9aff225a6167f37e3f104feb59d6c495e15759
DIST botocore-1.27.2.tar.gz 9026413 BLAKE2B 013724df76fb87c8e7731401d09774bec303aced7c3a01bb97935865f34193d1f313d49f32c1f6b7addab9b24384f26caca44b03ba0e77014821dc7cab5142ef SHA512 85045c13fa935b017f66edc132d2a31da2ecbe0c7bfcab369cb1d5f76d8a1401d303ab7d3e2ce95d53e9a59ea81dbf5380c1106169d84f40b21cbb926e35abb9
diff --git a/dev-python/botocore/botocore-1.26.5.ebuild b/dev-python/botocore/botocore-1.26.5.ebuild
deleted file mode 100644
index c95d40f1e265..000000000000
--- a/dev-python/botocore/botocore-1.26.5.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="
- https://github.com/boto/botocore/
- https://pypi.org/project/botocore/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- <dev-python/jmespath-2[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/botocore-1.26.0-py311.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
-
- # unbundle deps
- rm -r botocore/vendored || die
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on bundled six
- tests/functional/test_six_imports.py::test_no_bare_six_imports
- tests/functional/test_six_threading.py::test_six_thread_safety
- )
-
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}
diff --git a/dev-python/botocore/botocore-1.27.0.ebuild b/dev-python/botocore/botocore-1.27.0.ebuild
deleted file mode 100644
index 2fb86c59b25e..000000000000
--- a/dev-python/botocore/botocore-1.27.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="
- https://github.com/boto/botocore/
- https://pypi.org/project/botocore/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- <dev-python/jmespath-2[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/botocore-1.26.0-py311.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
-
- # unbundle deps
- rm -r botocore/vendored || die
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on bundled six
- tests/functional/test_six_imports.py::test_no_bare_six_imports
- tests/functional/test_six_threading.py::test_six_thread_safety
- )
-
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}
diff --git a/dev-python/botocore/botocore-1.27.1.ebuild b/dev-python/botocore/botocore-1.27.1.ebuild
deleted file mode 100644
index 2fb86c59b25e..000000000000
--- a/dev-python/botocore/botocore-1.27.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="
- https://github.com/boto/botocore/
- https://pypi.org/project/botocore/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- <dev-python/jmespath-2[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/botocore-1.26.0-py311.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
-
- # unbundle deps
- rm -r botocore/vendored || die
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on bundled six
- tests/functional/test_six_imports.py::test_no_bare_six_imports
- tests/functional/test_six_threading.py::test_six_thread_safety
- )
-
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}