summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 07:11:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 08:09:13 +0100
commit1eeb52fad2491994330a2d05b30f1f7126f6b60d (patch)
tree772d38070ac74c5dc9414cfb5c3e2b4ccc83c4d3
parentdev-python/mkdocs-material: Bump to 8.5.11 (diff)
downloadgentoo-1eeb52fad2491994330a2d05b30f1f7126f6b60d.tar.gz
gentoo-1eeb52fad2491994330a2d05b30f1f7126f6b60d.tar.bz2
gentoo-1eeb52fad2491994330a2d05b30f1f7126f6b60d.zip
dev-python/pkginfo: Bump to 1.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pkginfo/Manifest1
-rw-r--r--dev-python/pkginfo/pkginfo-1.9.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index a2e5e5a27ee6..1abf1f112ef4 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,2 +1,3 @@
DIST pkginfo-1.8.3.tar.gz 375734 BLAKE2B a3e9779bcb7cd326d8bd8137fa388055032fd4ee7732d47a341807201a97f1d44652d8e46adefd301cf7cd3c1d041e49a6ed2b8752e12347a8a2a2349cf397bd SHA512 54a67bdf078b38600651cb94afa62e9d86fce512022b1e79eb4565289ae3fad2325647654704488968e18cd85cbba4bd0ce28392fd09ae9638ee449e802273eb
DIST pkginfo-1.9.0.tar.gz 376601 BLAKE2B 1823140bcd109cf2549f0c7f8db4315880a86030a8400838755664794a7cac94998a6a20832db6b29d5f8623fc16d0bed477eb48750184ba04b6440063d6bf02 SHA512 5189929a80aedbeb65ad3b243d6f916854887e34d3489eab71a6ca69ab82d0fb2cc62ec7a49999890eb323be981d35505a6f47d2debc83cfa1cc8bb04523dcb0
+DIST pkginfo-1.9.2.tar.gz 377091 BLAKE2B e217e3d58fbc7a4efe7321d1eb4f6c95ea75cfcdcbdd06c0f8b728eb1ec18c5800a7ed6f6338996c60f5f251f36d40b40c20d0b1700956dd8a23a6e40594a356 SHA512 16eb4708040811a21184e5fff1bbbde775360718fa67df97f56c646381f6f1e58967920753437e5759e4d88c31a4f10c1e4d8be2380981939e51e4ee140dbeda
diff --git a/dev-python/pkginfo/pkginfo-1.9.2.ebuild b/dev-python/pkginfo/pkginfo-1.9.2.ebuild
new file mode 100644
index 000000000000..0d4b0b97213c
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs