summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-11-03 16:55:58 -0600
committerSam James <sam@gentoo.org>2023-11-19 18:32:25 +0000
commit1eebb1b9834dc373677477cf2063ace0e7a32348 (patch)
tree8d8e0bb80a1c43bcf88a9b7539bac9b89ba1e2d7
parentdev-haskell/cabal: drop 3.2.1.0-r2 (diff)
downloadgentoo-1eebb1b9834dc373677477cf2063ace0e7a32348.tar.gz
gentoo-1eebb1b9834dc373677477cf2063ace0e7a32348.tar.bz2
gentoo-1eebb1b9834dc373677477cf2063ace0e7a32348.zip
dev-haskell/cabal: Add upper bound to ghc deps
Old versions of Cabal will not build on new versions of GHC, and will give rise to this error if you try: Unknown/unsupported 'ghc' version detected (Cabal 3.0 supports 'ghc' version < 9.1): /usr/bin/ghc is version 9.2.8 (In reality, despite the contents of the error message, Cabal-3.4 supports <ghc-9.1, Cabal-3.6 supports <ghc-9.3, etc.) Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild2
-rw-r--r--dev-haskell/cabal/cabal-3.6.3.0.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild b/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild
index ce7ccae0f5c3..c6c1f1ec4d33 100644
--- a/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild
+++ b/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild
@@ -25,7 +25,7 @@ KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
RDEPEND="
- >=dev-lang/ghc-8.4.3:=
+ >=dev-lang/ghc-8.4.3:= <dev-lang/ghc-9.1:=
"
DEPEND="${RDEPEND}
"
diff --git a/dev-haskell/cabal/cabal-3.6.3.0.ebuild b/dev-haskell/cabal/cabal-3.6.3.0.ebuild
index 65f9f2dbf9f7..ecf27935c764 100644
--- a/dev-haskell/cabal/cabal-3.6.3.0.ebuild
+++ b/dev-haskell/cabal/cabal-3.6.3.0.ebuild
@@ -21,7 +21,7 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
- >=dev-lang/ghc-9.2.4:=
+ >=dev-lang/ghc-9.2.4:= <dev-lang/ghc-9.3:=
"
DEPEND="${RDEPEND}
"