summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-27 22:15:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-27 22:15:48 +0100
commit1f0961dbdb3c4c40ca6fb4a310d837c4bd979b3f (patch)
tree045b3345bd708e1d899b70807fbd269e645633d1
parentdev-python/cliff: Remove old (diff)
downloadgentoo-1f0961dbdb3c4c40ca6fb4a310d837c4bd979b3f.tar.gz
gentoo-1f0961dbdb3c4c40ca6fb4a310d837c4bd979b3f.tar.bz2
gentoo-1f0961dbdb3c4c40ca6fb4a310d837c4bd979b3f.zip
dev-python/gitdb: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gitdb/Manifest1
-rw-r--r--dev-python/gitdb/gitdb-4.0.7.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/gitdb/Manifest b/dev-python/gitdb/Manifest
index e5dc9714e80f..f044b27a55a3 100644
--- a/dev-python/gitdb/Manifest
+++ b/dev-python/gitdb/Manifest
@@ -1,2 +1 @@
-DIST gitdb-4.0.7.tar.gz 394664 BLAKE2B 4a4586ac276c719110e7ad9ddccca8c0f45cca42f6740d990a974b043a749148088c495ad1939794382ff4094afa712cfa7f17619f371423f1b7a10e65ce72d2 SHA512 db63a613ee59249a3fccbd09fc0eca5747b166180bb5885737f849e339e81dfacd04f65e438fef241cf013cde33fe8c99a569c1599b2b5defd37b50e87dbdb0a
DIST gitdb-4.0.8.tar.gz 394637 BLAKE2B 8eb3b04664df0fb40b93ee814d94a2526d62127c3dd7d0908f8c3ab9c3fc4d7ad368ad6a4288e509ce2f6e43348cb4f3761aaf404040bad1c59bc920517888af SHA512 fa883bf135080a9defa039bf1f13aebdb91c7e8d397c870e24d7c13acc1b30fc32c6299b43c117657382c1908ace748b0967bc53e02c2d73633cc8603fcb8003
diff --git a/dev-python/gitdb/gitdb-4.0.7.ebuild b/dev-python/gitdb/gitdb-4.0.7.ebuild
deleted file mode 100644
index 908e5834607d..000000000000
--- a/dev-python/gitdb/gitdb-4.0.7.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="GitDB is a pure-Python git object database"
-HOMEPAGE="
- https://github.com/gitpython-developers/gitdb
- https://pypi.org/project/gitdb/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-vcs/git
- )"
-
-distutils_enable_tests nose
-
-src_prepare() {
- # remove unnecessary version restriction
- # https://github.com/gitpython-developers/gitdb/issues/67
- sed -i -e '/smmap/s:,<4::' setup.py || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- local i
-
- mkdir "${T}"/repo || die
- cd "${T}"/repo || die
-
- for (( i = 0; i < 2500; ++i )); do
- echo "${i}" > file"${i}" || die
- done
-
- git init || die
- git config user.email "you@example.com" || die
- git config user.name "Your Name" || die
- git add -A || die
- git commit -q -m ".." || die
- git clone --bare "${T}"/repo "${T}"/repo.git || die
- cd "${S}" || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- #TRAVIS=1 disables performance tests which rely on the gitdb repo
- local -x TRAVIS=1
- local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}