summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-31 01:43:19 +0100
committerSam James <sam@gentoo.org>2023-03-31 01:55:00 +0100
commit1f0bb79f67cb4d4466867b3d0db94e6ee75baae5 (patch)
tree3c635ac64586af4769c276cabb3e8b700ea40e2e
parentpackage.mask: Last rite dev-ruby/ddmemoize (diff)
downloadgentoo-1f0bb79f67cb4d4466867b3d0db94e6ee75baae5.tar.gz
gentoo-1f0bb79f67cb4d4466867b3d0db94e6ee75baae5.tar.bz2
gentoo-1f0bb79f67cb4d4466867b3d0db94e6ee75baae5.zip
media-libs/libcaca: drop broken + masked Ruby support
Empty USE_RUBY isn't valid and USE=ruby was masked anyway. It's just that this is now exposed by the eclass dying on invalid USE_RUBY. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/libcaca/libcaca-0.99_beta19-r11.ebuild17
-rw-r--r--profiles/base/package.use.mask4
2 files changed, 4 insertions, 17 deletions
diff --git a/media-libs/libcaca/libcaca-0.99_beta19-r11.ebuild b/media-libs/libcaca/libcaca-0.99_beta19-r11.ebuild
index fe075d869285..25ffa5d82c40 100644
--- a/media-libs/libcaca/libcaca-0.99_beta19-r11.ebuild
+++ b/media-libs/libcaca/libcaca-0.99_beta19-r11.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-RUBY_OPTIONAL=yes
-
-inherit autotools ruby-ng flag-o-matic toolchain-funcs multilib-minimal
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
MY_P=${P/_/.}
DESCRIPTION="A library that creates colored ASCII-art graphics"
@@ -16,7 +14,7 @@ S="${WORKDIR}/all/${MY_P}"
LICENSE="GPL-2 ISC LGPL-2.1 WTFPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="doc imlib ncurses opengl ruby slang static-libs test truetype X"
+IUSE="doc imlib ncurses opengl slang static-libs test truetype X"
RESTRICT="!test? ( test )"
REQUIRED_USE=""
@@ -65,10 +63,6 @@ PATCHES=(
"${FILESDIR}/fix-css-path.patch"
)
-pkg_setup() {
- use ruby && ruby-ng_pkg_setup
-}
-
src_prepare() {
# bug #339962
sed -i -e '/doxygen_tests = check-doxygen/d' test/Makefile.am || die
@@ -103,9 +97,6 @@ multilib_src_configure() {
if multilib_is_native_abi; then
# bug #44128
export VARTEXFONTS="${T}/fonts"
-
- # bug #329651
- use ruby && use ruby_targets_${USE_RUBY} && export RUBY=$(ruby_implementation_command ${USE_RUBY})
fi
local myeconfargs=(
@@ -120,7 +111,7 @@ multilib_src_configure() {
$(use_enable imlib imlib2)
$(use_enable test cppunit)
--disable-java
- $(multilib_native_use_enable ruby)
+ --disable-ruby
--disable-python
--disable-csharp
$(multilib_native_use_enable doc)
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 35f06b4ef11e..158be19da4d4 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -695,10 +695,6 @@ sys-boot/refind custom-cflags
# Does not build
sci-libs/linux-gpib php
-# Michał Górny <mgorny@gentoo.org> (2017-05-15)
-# Mask ruby20-only compatible packages
-~media-libs/libcaca-0.99_beta19 ruby
-
# Mike Gilbert <floppym@gentoo.org> (2017-02-16)
# Multiple test failures.
sys-boot/grub:2 test