summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-01-29 11:20:59 -0500
committerCraig Andrews <candrews@gentoo.org>2018-01-29 11:21:18 -0500
commit1f224179ffb9bedd82846f659d0a8ec11eeb5694 (patch)
tree3e3f51ef12476bb971dcbbbc028209b035f3f3fc
parentapp-eselect/eselect-php-0.9.4-r5: alpha stable (diff)
downloadgentoo-1f224179.tar.gz
gentoo-1f224179.tar.bz2
gentoo-1f224179.zip
net-p2p/cpuminer-opt: 3.8.0 version bump
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.0.ebuild46
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild7
3 files changed, 50 insertions, 4 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 06916ddcbdd4..f52f72179743 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,2 +1,3 @@
DIST cpuminer-opt-3.7.10.tar.gz 1629412 BLAKE2B 7ac3144345aad4b7616a5293092452b4206c820ae4d316ca8a5ed6f0303a10fec0d231eeb5d5064fea032ace2110425cd6127f1735a14a9d551100438ad6baeb SHA512 9845e09ffd9f4c0c27a0ead1d12578b9f29cdb9377cca14b06f762e3885c5cfb401344406312737b18b656535079e59ed214b5035e2f67bba6e2cb2f644aa62b
DIST cpuminer-opt-3.7.9.tar.gz 1623402 BLAKE2B f9e225989bf1f2dd249de1ed43e7e1532c8e825f6fb25e54020a0f4382ab156a9fd7463e82510a90c5c6f71b8a9749c94cc4acc01d05b6f189766099a5772fec SHA512 17457900cad97b57d92160aba8d22256a39660dc29afbcd5be35b3e9c9045f81cd43332c7890cbde44427345eff61a6a1346ce31620e281160b5acaf729863d3
+DIST cpuminer-opt-3.8.0.tar.gz 1656474 BLAKE2B 145126762aeb245d042c1a208b60fd4727b450b77ab2585043b13b82b61b947dea0db2489de08e619dcd54b8eb1ec429f83f21ce1e49c34e140f585eccdd14f0 SHA512 c610d58236c5d84a850e68e172d3fdfede5b86aefa8ff09890ffc43d47efd4754aeb345f6b5fd48b6afcbc771541418f6fde1c9e621ad89c17d2dad4c16151f9
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.0.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.0.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
index 9d637b9169d3..a1f4a660f6b9 100644
--- a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,7 +7,7 @@ inherit autotools flag-o-matic systemd
DESCRIPTION="Optimized multi algo CPU miner"
HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
-IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 curl libressl"
+IUSE="cpu_flags_x86_sse2 curl libressl"
LICENSE="GPL-2"
SLOT="0"
REQUIRED_USE="cpu_flags_x86_sse2"
@@ -25,7 +25,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
KEYWORDS="~amd64"
- SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
src_prepare() {
@@ -35,7 +35,6 @@ src_prepare() {
src_configure() {
append-ldflags -Wl,-z,noexecstack
- use cpu_flags_x86_avx2 && append-cflags "-DFOUR_WAY"
econf --with-crypto $(use_with curl)
}