summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-23 17:56:18 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-28 16:34:44 +0200
commit1f22873c9fe5531cd633388d860f8a66cbe457d5 (patch)
treea1c5e02c2d6bceac05b95eb1a6a57a837ca406a5
parentnet-misc/anydesk: switch sound support to optfeature (diff)
downloadgentoo-1f22873c.tar.gz
gentoo-1f22873c.tar.bz2
gentoo-1f22873c.zip
dev-libs/hyperscan: add warning message for rspamd users
Different version of hyperscan causes runtime failures in mail-filter/rspamd. Workaround is to remove /var/lib/rspamd/*.hs* files. Let's warn users who might be affected because they have rspamd installed. Upstream-issue: https://github.com/rspamd/rspamd/issues/4409 Reported-by: Jakub Gajdoš <jakub@gdos.sk> Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29750 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/hyperscan/hyperscan-5.4.0.ebuild8
-rw-r--r--dev-libs/hyperscan/hyperscan-5.4.1.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-libs/hyperscan/hyperscan-5.4.0.ebuild b/dev-libs/hyperscan/hyperscan-5.4.0.ebuild
index 34d42c4677bb..55f108b37fa3 100644
--- a/dev-libs/hyperscan/hyperscan-5.4.0.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.4.0.ebuild
@@ -55,3 +55,11 @@ src_configure() {
src_test() {
"${BUILD_DIR}"/bin/unit-hyperscan || die
}
+
+pkg_postinst() {
+ if has_version 'mail-filter/rspamd'; then
+ elog "There is known issue with mail-filter/rspamd when hyperscan version changes."
+ elog "Known workaround is to remove hyperscan databases ${EROOT}/var/lib/rspamd/*.hs*"
+ elog "See https://github.com/rspamd/rspamd/issues/4409 for more information."
+ fi
+}
diff --git a/dev-libs/hyperscan/hyperscan-5.4.1.ebuild b/dev-libs/hyperscan/hyperscan-5.4.1.ebuild
index 4377ae025213..2984a1ad61f2 100644
--- a/dev-libs/hyperscan/hyperscan-5.4.1.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.4.1.ebuild
@@ -55,3 +55,11 @@ src_configure() {
src_test() {
"${BUILD_DIR}"/bin/unit-hyperscan || die
}
+
+pkg_postinst() {
+ if has_version 'mail-filter/rspamd'; then
+ elog "There is known issue with mail-filter/rspamd when hyperscan version changes."
+ elog "Known workaround is to remove hyperscan databases ${EROOT}/var/lib/rspamd/*.hs*"
+ elog "See https://github.com/rspamd/rspamd/issues/4409 for more information."
+ fi
+}