summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-07 13:12:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-07 16:41:40 +0100
commit1f28bb6bcb95bc25fae85140b653007afb9a7869 (patch)
treeab8dd81267a249959cc20d0629c9db4afc6f8494
parentmedia-video/vlc: Drop 3.0.14-r7 (diff)
downloadgentoo-1f28bb6b.tar.gz
gentoo-1f28bb6b.tar.bz2
gentoo-1f28bb6b.zip
net-libs/ldns: Drop 1.7.1-r4, EAPI6--
Closes: https://bugs.gentoo.org/783726 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/ldns/ldns-1.7.1-r4.ebuild113
1 files changed, 0 insertions, 113 deletions
diff --git a/net-libs/ldns/ldns-1.7.1-r4.ebuild b/net-libs/ldns/ldns-1.7.1-r4.ebuild
deleted file mode 100644
index ba6d831e94aa..000000000000
--- a/net-libs/ldns/ldns-1.7.1-r4.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit epatch multilib-minimal python-single-r1
-
-DESCRIPTION="a library with the aim to simplify DNS programming in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/3"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa ed25519 ed448 gost python static-libs vim-syntax"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- ecdsa? (
- >=dev-libs/openssl-1.0.1e:0=[-bindist(-),${MULTILIB_USEDEP}]
- )
- ed25519? (
- >=dev-libs/openssl-1.1.0:0=[-bindist(-),${MULTILIB_USEDEP}]
- )
- ed448? (
- >=dev-libs/openssl-1.1.1:0=[-bindist(-),${MULTILIB_USEDEP}]
- )
- >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )
-"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-multilib_src_configure() {
- # >=openssl-1.1.0 required for dane-ta
- if has_version "<dev-libs/openssl-1.1.0"; then
- local dane_ta_usage="--disable-dane-ta-usage"
- else
- local dane_ta_usage=""
- fi
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable gost) \
- $(use_enable ecdsa) \
- $(use_enable ed25519) \
- $(use_enable ed448) \
- $(use_enable dane) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --with-ssl="${EPREFIX}"/usr \
- --enable-sha2 \
- --without-drill \
- --without-examples \
- ${dane_ta_usage} \
- --disable-rpath
-}
-
-src_prepare() {
- default
- epatch "${FILESDIR}/${P}-Makefile.patch"
- # remove non-existing dependency for target packaging/libldns.pc
- sed -i 's,packaging/libldns.pc.in,,' "${S}"/Makefile.in || die 'could not patch Makefile.in'
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- find "${D}" -name '*.la' -delete || die
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-
- einfo
- elog "Install net-dns/ldns-utils if you want drill and examples"
- einfo
-}