summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-24 07:09:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-24 08:10:41 +0200
commit1f32228c36ef48fcd8ac83ffa109afefa6939294 (patch)
tree6afd1147683ceeac1db0b12c77cb8f44b53a088a
parentdev-python/mkdocs-material: Bump to 9.1.17 (diff)
downloadgentoo-1f32228c36ef48fcd8ac83ffa109afefa6939294.tar.gz
gentoo-1f32228c36ef48fcd8ac83ffa109afefa6939294.tar.bz2
gentoo-1f32228c36ef48fcd8ac83ffa109afefa6939294.zip
dev-python/jsonschema-specifications: Bump to 2023.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsonschema-specifications/Manifest1
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index c36202eeb8dd..5d12559b27e4 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1 +1,2 @@
DIST jsonschema_specifications-2023.5.2.tar.gz 12581 BLAKE2B 74029c066e3c620126ed0ed7e70a9b63c017aeab827b0187f8c8c5964c2e1ef68a83489f4646d79653c38fcec45bc001189fc09295ac1f569ed288f2dc469459 SHA512 222a70e3c1673c6f3d27f5d6561d4ba192c61a8a6f86e726939d1e29843eeca82de306a889540ab352a5c2332cf30d810db956aa5094f2a6bc6607b7169513fd
+DIST jsonschema_specifications-2023.6.1.tar.gz 12645 BLAKE2B 9dea1acae9e53a9f8ff93dd54d5df3bb1dd960036dfcc4dcc0c6287ae816c0ca60c139b35aa14901e2e9f61dca339cf9d84a5c5e8f91a62a40696db9daa1a099 SHA512 b7a0d7fdc642e08cf3515dfae6d8cbb14e4d40c3b1fe3cb6c87ee11c47a9d6ede33b28d9fe6f3d4f0ff1807469a015cd8fcacff9575a356a74b462af9681aa6c
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild
new file mode 100644
index 000000000000..46d56e086c48
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/referencing-0.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest