summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-03 08:56:31 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-04 14:40:22 -0400
commit1f4aede49a917f0e5091e64c9602cf8bac2d8e99 (patch)
tree0ee251fd22bab8dbfd769f8926c8599bfb4a0b8d
parentwww-client/microsoft-edge-beta: remove old (diff)
downloadgentoo-1f4aede49a917f0e5091e64c9602cf8bac2d8e99.tar.gz
gentoo-1f4aede49a917f0e5091e64c9602cf8bac2d8e99.tar.bz2
gentoo-1f4aede49a917f0e5091e64c9602cf8bac2d8e99.zip
gnome-extra/gnome-boxes: Version bump to 44.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30458 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-44.1.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index fb88054b8464..319d2346c3f3 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,2 +1,3 @@
DIST gnome-boxes-43.3.tar.xz 1235612 BLAKE2B b91953a77aae69a8307c4c9bb6944f9c62b49ac67aef352ba349a84b820bb6aa791cc27ce5a5402b55d3c822439f90700083b66c216a0fac83bb1a96e8410cca SHA512 ad53b1538d146aae9ec4f40d7cd8dc75e3ec54c903b0c2debd56445e613445281e9a641398cdecf584f1fbe8d31fc51d5309ce76b4eb8ed1eb0e0018341d7b4b
DIST gnome-boxes-44.0.tar.xz 1239216 BLAKE2B df960b76fa64856458d40ffeb1e68629cc830ed10f80430712c1a93337d85ee8cb0badfa7c3382d81a8b0a3a2587a1ab36daa7d931c03e9d9e8a0e27b986fde9 SHA512 9d03547262dfb79bda2f0cc008a127a9bada758e85264ee8d2912b25e5bc116ab7df522ba56b90e598b130714b5dbb0b046b6baa9e4722b6fd298355c5aad7ec
+DIST gnome-boxes-44.1.tar.xz 1239656 BLAKE2B 86a414982b95840f198dc5adc0bbead117405339a8ab997248768583d6abc5cba635540ec24029e0fc5771926728f6696aa117eb79a9c6dca7dfbfc60dff654c SHA512 75464f0ce6ff72c9da4cf4966f566674f0e16b4c7a51ae472761e4bd9c8fc654b4833f9f8bdc4c3e3581d00e3548ed3d731c4d8d8a05e610126f350136d8f31f
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-44.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-44.1.ebuild
new file mode 100644
index 000000000000..fe0ddd039b58
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-44.1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and it should be better to use the .vapi from the same libsoup version
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=gui-libs/libhandy-1.5.0:1
+ >=sys-libs/libosinfo-1.10.0-r1
+ net-libs/libsoup:3.0
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-4.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ >=net-libs/webkit-gtk-2.38.0:4.1
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+" # gobject-introspection needed for libovf subproject
+# These are called via exec():
+# sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# sys-apps/policycoreutils restorecon is used for checking selinux context
+# app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# sys-auth/polkit used for making all libvirt system disks readable via "pkexec chmod a+r" that aren't already readable to the user (libvirt system importer)
+# app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:3.0[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ -Duefi=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}