summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2018-07-13 17:44:52 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-16 14:44:49 +0100
commit1f4dbeda156c024b8c25d19f6ab5691f740f3695 (patch)
treec95186ab0164d2191d9ee3c4667f63f8fd1c11a1
parentapp-misc/elasticsearch: stop using /etc/conf.d for systemd (diff)
downloadgentoo-1f4dbeda.tar.gz
gentoo-1f4dbeda.tar.bz2
gentoo-1f4dbeda.zip
app-misc/elasticsearch: drop old
Package-Manager: Portage-2.3.42, Repoman-2.3.9
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.3.1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-6.3.1.ebuild b/app-misc/elasticsearch/elasticsearch-6.3.1.ebuild
deleted file mode 100644
index f3e63754b4a0..000000000000
--- a/app-misc/elasticsearch/elasticsearch-6.3.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit systemd user
-
-DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
-HOMEPAGE="https://www.elastic.co/products/elasticsearch"
-SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${PN}-oss-${PV}.tar.gz"
-LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="virtual/jre:1.8"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
-}
-
-src_prepare() {
- default
-
- rm -v bin/*.{bat,exe} LICENSE.txt || die
-}
-
-src_install() {
- keepdir /etc/${PN}
- keepdir /etc/${PN}/scripts
-
- insinto /etc/${PN}
- doins -r config/.
- rm -rv config || die
-
- fowners root:${PN} /etc/${PN}
- fperms 2750 /etc/${PN}
-
- insinto /usr/share/${PN}
- doins -r .
-
- exeinto /usr/share/${PN}/bin
- doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
-
- chmod +x "${ED}"/usr/share/${PN}/bin/* || die
-
- keepdir /var/{lib,log}/${PN}
- fowners ${PN}:${PN} /var/{lib,log}/${PN}
- fperms 0750 /var/{lib,log}/${PN}
- dodir /usr/share/${PN}/plugins
-
- insinto /etc/sysctl.d
- newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
-
- newconfd "${FILESDIR}/${PN}.conf.3" ${PN}
- newinitd "${FILESDIR}/${PN}.init.4" ${PN}
-
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
- systemd_newunit "${FILESDIR}"/${PN}.service.2 ${PN}.service
-}
-
-pkg_postinst() {
- elog
- elog "You may create multiple instances of ${PN} by"
- elog "symlinking the init script:"
- elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
- elog
- elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
- elog "from /etc/elasticsearch into the configuration directory of the instance:"
- elog "/etc/${PN}/instance"
- elog
-}