summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-08 22:36:57 +0100
committerSam James <sam@gentoo.org>2023-04-08 22:36:57 +0100
commit1f5108f418a76377ea8907fec53856a388d7f5a7 (patch)
treec989a4e18af3eac95412ab0fad2fb661e3b8fea0
parentnet-libs/libpcap: add 1.10.4 (diff)
downloadgentoo-1f5108f418a76377ea8907fec53856a388d7f5a7.tar.gz
gentoo-1f5108f418a76377ea8907fec53856a388d7f5a7.tar.bz2
gentoo-1f5108f418a76377ea8907fec53856a388d7f5a7.zip
net-analyzer/tcpdump: add 4.99.4
Bug: https://bugs.gentoo.org/904041 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/tcpdump/Manifest2
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.99.4.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/Manifest b/net-analyzer/tcpdump/Manifest
index aff8baf7a1ae..1b6e578d252e 100644
--- a/net-analyzer/tcpdump/Manifest
+++ b/net-analyzer/tcpdump/Manifest
@@ -4,3 +4,5 @@ DIST tcpdump-4.99.2.tar.gz 1897480 BLAKE2B be13fbf493478270c8ebc034a3c1467907a00
DIST tcpdump-4.99.2.tar.gz.sig 442 BLAKE2B 011c93803a1c339f9ce46dedb8e3420d77c5362575061c9b852647d8e8de6936079150240b444f660a84b9e45337960b8878e7c4de1f4e6ad2fff16225811d24 SHA512 33704e9b2ece65ca8a1fbf8234088e561f132a561ac859da32c7fb4d4caaeabd9a4b50ac8f939e48c18e672dade9393c7e56bc838ec8ac9828be5360e99e5692
DIST tcpdump-4.99.3.tar.gz 1901814 BLAKE2B 8e8adda6df40f3a79cbeb80bd01d43834e0b3ec44c8227bda2260b43ea0852f76beb02199120cca16adae0d793841cf684e7e276e520f49479a1b04ab1dc4821 SHA512 e1442e923d89f367cfe403dc460d0d46e19a241470d56b30b7a411bedd8d21a78c428f20ffe725cbb4fa5068f7dcc5c93d206e1a8d53feb9bccc6f0cda8bf0f9
DIST tcpdump-4.99.3.tar.gz.sig 442 BLAKE2B 97dbac4534f9b9daf0ab89d6a230835690737827330d4a6f15e7450bd8aed24af2bc097bf41511bb40534687623ffe63fb766c5e344ce66483c9dd5f34427155 SHA512 a7dfd95c11fa9066740552acc9ebfa1c674ba9242dfb6dddf27658845245b8677b4c2da392cfe1447f32b929e108e9ff5326a94cdc0be9502a05e0efc15a5934
+DIST tcpdump-4.99.4.tar.gz 1903612 BLAKE2B f100e10774574ef04a770bc30d4e2d06fd0f1f16a7b2c88848be6e8290cc4838666ff378d9f78fdc418f4ffab9716a11214edc3588c292cb5ff39636cd7cfd2d SHA512 cb51e19574707d07c0de90dd4c301955897f2c9f2a69beb7162c08f59189f55625346d1602c8d66ab2b4c626ea4b0df1f08ed8734d2d7f536d0a7840c2d6d8df
+DIST tcpdump-4.99.4.tar.gz.sig 442 BLAKE2B 2ee35036d86f643b378591c0eb93d8a0f08cb2f0e3638bde25515d550b40fef1bf0eb6c876d4d6512fa795041b0703954ca884c646c4af8771b4bc4049e7609a SHA512 bec395f0f595a37121bc144bac133f3fb31c6c1007cdadf061e4437d6fe2406c0cb0d5b68b5c63e03b932c783bfb58f0af0b7e8a58bb81beb9de6a0d681620e8
diff --git a/net-analyzer/tcpdump/tcpdump-4.99.4.ebuild b/net-analyzer/tcpdump/tcpdump-4.99.4.ebuild
new file mode 100644
index 000000000000..8d03b876b291
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.99.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A tool for network monitoring and data acquisition"
+HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpdump"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/tcpdump.asc
+ inherit verify-sig
+
+ SRC_URI="https://www.tcpdump.org/release/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://www.tcpdump.org/release/${P}.tar.gz.sig )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+drop-root +smi +ssl +samba suid test"
+REQUIRED_USE="test? ( samba )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=net-libs/libpcap-1.10.1
+ drop-root? (
+ acct-group/pcap
+ acct-user/pcap
+ sys-libs/libcap-ng
+ )
+ smi? ( net-libs/libsmi )
+ ssl? (
+ >=dev-libs/openssl-0.9.6m:=
+ )
+ suid? (
+ acct-group/pcap
+ acct-user/pcap
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-lang/perl
+ )
+"
+BDEPEND="drop-root? ( virtual/pkgconfig )"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-tcpdump )"
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-libdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root cap-ng) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${ESYSROOT}/usr") \
+ $(usex drop-root "--with-user=pcap" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root ; then
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid ; then
+ fowners root:pcap /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump, add them to the pcap group."
+}