summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-03 20:14:38 +0000
committerSam James <sam@gentoo.org>2021-04-03 20:15:11 +0000
commit1fa3cfbe816717289b5434a48a907532df4d3ec4 (patch)
treeac897fd6b0f7993cd16dd006fc56d6a56b0d6ccc
parentgames-util/wiiload: port to EAPI 7 (diff)
downloadgentoo-1fa3cfbe816717289b5434a48a907532df4d3ec4.tar.gz
gentoo-1fa3cfbe816717289b5434a48a907532df4d3ec4.tar.bz2
gentoo-1fa3cfbe816717289b5434a48a907532df4d3ec4.zip
media-gfx/photopc: EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/photopc/files/photopc-3.07-implicit-declarations.patch36
-rw-r--r--media-gfx/photopc/photopc-3.07.ebuild9
2 files changed, 42 insertions, 3 deletions
diff --git a/media-gfx/photopc/files/photopc-3.07-implicit-declarations.patch b/media-gfx/photopc/files/photopc-3.07-implicit-declarations.patch
new file mode 100644
index 000000000000..dcf155f85190
--- /dev/null
+++ b/media-gfx/photopc/files/photopc-3.07-implicit-declarations.patch
@@ -0,0 +1,36 @@
+diff --git a/ctimez.c b/ctimez.c
+index 21a529d..ecd5616 100644
+--- a/ctimez.c
++++ b/ctimez.c
+@@ -48,6 +48,7 @@ static char *rcsid="$Id: ctimez.c,v 1.7 1999/11/09 18:55:03 crosser Exp $";
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <stdio.h>
++#include <string.h>
+ #if TIME_WITH_SYS_TIME
+ # include <sys/time.h>
+ # include <time.h>
+diff --git a/eph_cmd.c b/eph_cmd.c
+index 7f90ad6..462eff0 100644
+--- a/eph_cmd.c
++++ b/eph_cmd.c
+@@ -89,6 +89,7 @@ static char *rcsid="$Id: eph_cmd.c,v 1.20 2001/08/28 06:28:01 crosser Exp $";
+ #include "config.h"
+ #endif
+ #include <stdio.h>
++#include <string.h>
+ #include "eph_io.h"
+ #include "eph_priv.h"
+
+diff --git a/fnames.c b/fnames.c
+index bf2db6d..8d19f4c 100644
+--- a/fnames.c
++++ b/fnames.c
+@@ -53,6 +53,7 @@ static char *rcsid="$Id: fnames.c,v 1.7 2001/01/11 06:49:57 crosser Exp $";
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <stdio.h>
++#include <string.h>
+ #if TIME_WITH_SYS_TIME
+ # include <sys/time.h>
+ # include <time.h>
diff --git a/media-gfx/photopc/photopc-3.07.ebuild b/media-gfx/photopc/photopc-3.07.ebuild
index 1d85a3d57011..a2e80fb2afd2 100644
--- a/media-gfx/photopc/photopc-3.07.ebuild
+++ b/media-gfx/photopc/photopc-3.07.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -12,7 +12,10 @@ SRC_URI="mirror://sourceforge/photopc/${P}.tar.gz"
LICENSE="photopc"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.07-implicit-declarations.patch
+)
src_compile() {
emake AR="$(tc-getAR)"