summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-13 14:07:36 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-13 14:08:50 +0100
commit1fae24dd8c4031c7449b5002130753bfed141c21 (patch)
tree8656071c492c30f393864bd42375fae9119ac1ab
parentdev-python/pyside6: add 6.4.1 (diff)
downloadgentoo-1fae24dd.tar.gz
gentoo-1fae24dd.tar.bz2
gentoo-1fae24dd.zip
dev-python/pyside6-tools: add 6.4.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/pyside6-tools/Manifest1
-rw-r--r--dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pyside6-tools/Manifest b/dev-python/pyside6-tools/Manifest
index 7ec686b25ee3..7d24903ef481 100644
--- a/dev-python/pyside6-tools/Manifest
+++ b/dev-python/pyside6-tools/Manifest
@@ -1 +1,2 @@
DIST pyside-setup-opensource-src-6.4.0.tar.xz 8551772 BLAKE2B 180d9f2182b8df04394677bbcb0765764d9de1f34064fc688a3ccae8ec37174b4a01fa70c80d98c7ca7fe6b45239225bd801c552d332e2c6fc4a3726535e72e9 SHA512 0517408f110830b888f04777c60b29479831604877da13c5a41a710888ebe53064f06d9b7b61d5c6e6a483ac5ee1639a63bb7f9844301df53e3e9ca8eafcf9e9
+DIST pyside-setup-opensource-src-6.4.1.tar.xz 8755436 BLAKE2B 9b88115374eb690282397fbf33fa6698043c77c8defd40fd0d711dee39aa4cd56af94533cf1703b87084e8755758fe636b877071a29043ee7f4c8e406e47cf38 SHA512 330eef5d63c5225e0d3ee8be1229e81ac04ec39772766fd2dfe197291a8153c00a2cd548ce6e49a0a198b3081535c79a7e649a6e9f03dfe67df68790543ea023
diff --git a/dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild b/dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild
new file mode 100644
index 000000000000..4b0012504051
--- /dev/null
+++ b/dev-python/pyside6-tools/pyside6-tools-6.4.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{8..11} )
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake python-r1
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="PySide development tools (pyside6-lupdate with support for Python)"
+HOMEPAGE="https://wiki.qt.io/PySide6"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-${PV}-src/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/sources/pyside-tools"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ ~dev-python/pyside6-${PV}[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ pyside-tools_configure() {
+ local mycmakeargs=(
+ # the tools conflict with tools from Qt
+ -DNO_QT_TOOLS=yes
+ )
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_configure
+ }
+
+ python_foreach_impl pyside-tools_configure
+}
+
+src_compile() {
+ pyside-tools_compile() {
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_compile
+ }
+
+ python_foreach_impl pyside-tools_compile
+}
+
+src_install() {
+ pyside-tools_install() {
+ python_doexe "${BUILD_DIR}/"*.py
+ }
+
+ python_foreach_impl pyside-tools_install
+
+ einstalldocs
+}