summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 02:17:43 +0100
committerSam James <sam@gentoo.org>2021-04-03 17:10:26 +0100
commit1fbf6335aed32d25b8dc19eb6325b6c3fd83797e (patch)
treea0ba0f46ff21c2000999626883ba0992aad0d1b7
parentnet-analyzer/smokeping: eutils--, multilib--, QA fixes (diff)
downloadgentoo-1fbf6335aed32d25b8dc19eb6325b6c3fd83797e.tar.gz
gentoo-1fbf6335aed32d25b8dc19eb6325b6c3fd83797e.tar.bz2
gentoo-1fbf6335aed32d25b8dc19eb6325b6c3fd83797e.zip
net-analyzer/snortalog: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
index 18e2cd14b905..960612b2f88f 100644
--- a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
+++ b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=7
MY_P="${PN}_v${PV}"
-DESCRIPTION="a powerful perl script that summarizes snort logs"
+inherit edos2unix
+
+DESCRIPTION="A powerful perl script that summarizes snort logs"
HOMEPAGE="http://jeremy.chartier.free.fr/snortalog/"
SRC_URI="http://jeremy.chartier.free.fr/snortalog/downloads/${PN}/${MY_P}.tar"
+S="${WORKDIR}"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
IUSE="tk"
@@ -24,10 +26,16 @@ RDEPEND="
tk? ( dev-perl/Tk )
"
-S=${WORKDIR}
-
src_prepare() {
- edos2unix $(find conf/ modules/ -type f) ${PN}.* CHANGES
+ default
+
+ local convert=$(find conf/ modules/ -type f || die)
+ convert+=( ${PN}.* CHANGES )
+
+ local item
+ for item in ${convert[@]} ; do
+ edos2unix "${item}"
+ done
# fix paths, erroneous can access message
sed -i \