summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 09:36:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 10:16:03 +0100
commit1fd59ad91c9b79c4816c501ce3e7f34e8e9c3ae2 (patch)
treec0bfeddfe61e97ecfcbcdfa13dbb4afc91002f1e
parentdev-python/boto3: Bump to 1.16.50 (diff)
downloadgentoo-1fd59ad91c9b79c4816c501ce3e7f34e8e9c3ae2.tar.gz
gentoo-1fd59ad91c9b79c4816c501ce3e7f34e8e9c3ae2.tar.bz2
gentoo-1fd59ad91c9b79c4816c501ce3e7f34e8e9c3ae2.zip
dev-python/hypothesis: Bump to 5.49.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.49.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index ee4049ced25a..5b03e065e843 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-5.43.3.tar.gz 9103991 BLAKE2B e374edf17571c33e48dc8d259db
DIST hypothesis-python-5.43.4.tar.gz 9104105 BLAKE2B 08b8c9ac7ac72afcc4556ae2167af7b4ab79d505da8c9f6a11c91d211f26ccf320c8f5ed41458f5e34f75614ad4aecdbf6df62275868dc079c037390dcbc9e08 SHA512 065e1bdd878eab35f38105e8da3f5cf108670a51fd48ea1996bebedf8c8a152386d0eb5284ed43d4e588695a408b3a455a2e4757430e31bb5dbf0ece1f64d294
DIST hypothesis-python-5.47.0.tar.gz 9101964 BLAKE2B 7f57eebb6f27bf57373f2560612458bf9fd6233f8a9f254e59ced22c070a6f00453036c09b4e224b340843ad5027a9217e83473aaa13c1f94d354408d8d28799 SHA512 6a72469f0c2d0f16ddb56846a96f584104e726e4cd459abe30a744aef20ff50811e00e2a0feb72a3e3e6a3c6c7a7bf15be7c633640350e3bd550ad145c97c693
DIST hypothesis-python-5.48.0.tar.gz 9102665 BLAKE2B 985957be8e13ada8830bc9c8c3941d8ecec0ef3d3684a177aa4d9cc10c1d57972ddef9f5b35194197ede2d1e5932299a9a99f04eabe6dd8789a786300d1b5608 SHA512 b4d46db6aa9c3dc59f38e209b702580ce9fa0d8771792943cbe28fcca4ea434c23a6f49b9889cb28339d7282e529f1c947a7768c38d726b5e993a2ba3c029e00
+DIST hypothesis-python-5.49.0.tar.gz 9103591 BLAKE2B 158cbc38f6f2407d437656a7b94b5826193d427e06eca59d91b3fe85667282ec3392d72e7bbdf2bd952a495871a86814275883e2dcbc80758fcb3e68936d6d20 SHA512 96b7f98e7d87f82dac52a7b2de2bc0c29507cee05ee9a93f838e090e45a9f484ca75db1ab83ab52361b27e4e0f2747914ec09324fc188f6100c3397b1596778c
diff --git a/dev-python/hypothesis/hypothesis-5.49.0.ebuild b/dev-python/hypothesis/hypothesis-5.49.0.ebuild
new file mode 100644
index 000000000000..b910c24f12a5
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.49.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}