summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-08 09:24:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-08 09:43:57 +0100
commit1fd59aff689ddbddaa87822b902252998d35acc0 (patch)
treed6312a54eb6aff47e129d82205b464db024a3deb
parentdev-python/cwcwidth: Bump to 0.1.4 (diff)
downloadgentoo-1fd59aff.tar.gz
gentoo-1fd59aff.tar.bz2
gentoo-1fd59aff.zip
dev-python/lmfit: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lmfit/Manifest1
-rw-r--r--dev-python/lmfit/lmfit-1.0.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/lmfit/Manifest b/dev-python/lmfit/Manifest
index 2612f9b86213..c49f4457ad8a 100644
--- a/dev-python/lmfit/Manifest
+++ b/dev-python/lmfit/Manifest
@@ -1 +1,2 @@
DIST lmfit-1.0.1.tar.gz 258368 BLAKE2B bd2956cb9519f9303d0d2707b0333839ce471f62f53c907870bb6b8ab867cbcd1581d82a1959a6c3c734bd6b8074a769f0587706b3172800cbdef979db3a148d SHA512 1ae3e2cb25625a9b24c261d81c8f1ba0389266724581762f6e0a96140c84e43acd527ab1b83b862bf7b3b4c0b1b9755ee38d0c52e63fe89ea41f2d010b1e5c0d
+DIST lmfit-1.0.2.tar.gz 306039 BLAKE2B ab5fcda566f81f00a9d2371f6ae5b3477ed015c70e9b9faf8c5228e3f75f0bf9085d9bd3789042af7b46813d0b6c88f96da37ce295593a5368144d53f5f1799b SHA512 85adeac989117dab3cc9aaf216c37ea5087452351a7978238929216dd9d9be8b6b6790103d4fbbf5211a943c43fb99461750cf58287e2b18c27f66eeacc6ed9a
diff --git a/dev-python/lmfit/lmfit-1.0.2.ebuild b/dev-python/lmfit/lmfit-1.0.2.ebuild
new file mode 100644
index 000000000000..3be5d42ef10e
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/asteval-0.9.16[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # numpy warning mismatch
+ tests/test_confidence.py::test_confidence_warnings
+ tests/test_model.py::TestUserDefiniedModel::test_extra_param_issues_warning
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}