summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-30 15:03:06 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-30 15:03:06 +0100
commit1fd5b164fa298a2f5cd6160afd3068eced80b526 (patch)
tree4ad3e92a19fc1f08808a8457c5342d569fbd8f27
parentmedia-libs/x265: bump to 2.6 (diff)
downloadgentoo-1fd5b164.tar.gz
gentoo-1fd5b164.tar.bz2
gentoo-1fd5b164.zip
app-emulation/cadvisor: Initial version
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--app-emulation/cadvisor/Manifest1
-rw-r--r--app-emulation/cadvisor/cadvisor-0.28.2.ebuild26
-rw-r--r--app-emulation/cadvisor/files/cadvisor.initd18
-rw-r--r--app-emulation/cadvisor/metadata.xml11
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/Manifest b/app-emulation/cadvisor/Manifest
new file mode 100644
index 000000000000..3464eac2165f
--- /dev/null
+++ b/app-emulation/cadvisor/Manifest
@@ -0,0 +1 @@
+DIST cadvisor-0.28.2.tar.gz 4109967 BLAKE2B c55268a0768adeea75ecc2baa1093d5d5360d1e0be56cea467fe759278c7047060c4b78179a3a35801afbcf6415ffbeb7e0649c92e79878e5615c73a37eeabeb SHA512 e682b8e062ba373e5726a8076d5be75322e7c592bd751aa32da9a99e5d380a77fc4b376aa478b0beff18bae2bc8432d3a70542605681410d5e1e0b1919a6c252
diff --git a/app-emulation/cadvisor/cadvisor-0.28.2.ebuild b/app-emulation/cadvisor/cadvisor-0.28.2.ebuild
new file mode 100644
index 000000000000..25f12f419338
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.28.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-emulation/cadvisor/files/cadvisor.initd b/app-emulation/cadvisor/files/cadvisor.initd
new file mode 100644
index 000000000000..19e36b2c81a5
--- /dev/null
+++ b/app-emulation/cadvisor/files/cadvisor.initd
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="cAdvisor - Analyzes resource usage and performance characteristics of running containers"
+pidfile=${pidfile:-"/run/${SVCNAME}.pid"}
+user=${user:-${SVCNAME}}
+group=${group:-${SVCNAME}}
+
+command="/usr/bin/cadvisor"
+command_background="true"
+start_stop_daemon_args="--user ${user} --group ${group} \
+ --stdout /var/log/${SVCNAME}/${SVCNAME}.log \
+ --stderr /var/log/${SVCNAME}/${SVCNAME}.log"
+
+depend() {
+ after net
+}
diff --git a/app-emulation/cadvisor/metadata.xml b/app-emulation/cadvisor/metadata.xml
new file mode 100644
index 000000000000..9685b121c378
--- /dev/null
+++ b/app-emulation/cadvisor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/cadvisor</remote-id>
+ </upstream>
+</pkgmetadata>