summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-01-06 11:54:22 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-01-06 11:56:34 +0200
commit1fd8bba66dc2710707123e9f621f3af2bb8d1ffc (patch)
treeeca7a3f40539c839943713311175a822c3b0f715
parentnet-im/signal-cli-bin: add 0.12.7 (diff)
downloadgentoo-1fd8bba66dc2710707123e9f621f3af2bb8d1ffc.tar.gz
gentoo-1fd8bba66dc2710707123e9f621f3af2bb8d1ffc.tar.bz2
gentoo-1fd8bba66dc2710707123e9f621f3af2bb8d1ffc.zip
dev-libs/raft: add 0.19.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/raft-0.19.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index 343d5e79d268..6633205e660c 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1,2 +1,3 @@
DIST raft-0.18.2.tar.gz 335089 BLAKE2B 5e6221f3977a28b7c2bbc8b80e047b455b586b0c8dd3cb9dc31f43c48d745d017f8a7220f3b3072a7aabacb86751ea4ad02f7c00d9d9c59a419354416cca65b3 SHA512 bac167aaf02f121f6d5de9103b366591bdb0a40ee08bc20b9f4fadae4606631b1a8dec514009596601a79a91c63373c524ba59710a167a1259f1d3802fb1e341
DIST raft-0.18.3.tar.gz 335916 BLAKE2B f8dbf5f5ae89645a2d99e8b4b8c80560f64226deb2ac10e683f337c98f458fc5db7898b1e0fd9754f14ded07aa058daf88e03003a037729bdafdab3539b8ca46 SHA512 0ba0ea71b70d2769da22482cfeac5c59a17f4fa75d582075108411d633db75c7d6f6e817ce14768c15bd5c977987650e813019808932bafcac5753478c672916
+DIST raft-0.19.1.tar.gz 354736 BLAKE2B cfdb9a1948311debe99b56e0f9c1f19fb858248ab1138648e26a21d965cc488aea504711415ff569d2e80a15414a1f15ca9b34ff9b3de62b03580755cefe30b3 SHA512 4990dca1f61dcda82acaf043a5b81dd9a3b92a0f3e0be9b2c339d764be338220f2fab31ed8bae535153b1d81c86364d447774b52da2c8b90c5daa7b8718d7ae2
diff --git a/dev-libs/raft/raft-0.19.1.ebuild b/dev-libs/raft/raft-0.19.1.ebuild
new file mode 100644
index 000000000000..50ed76b86eac
--- /dev/null
+++ b/dev-libs/raft/raft-0.19.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+
+# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-hardening: most of these are covered on non-hardened Gentoo already.
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-hardening
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}