summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-06 10:16:22 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-06 10:17:29 +0200
commit1fe53bfdfa625625f3157581e9f3a6b21875eb67 (patch)
tree662ebee0a1684e689bbd442376f2111f5dc9c37e
parentwww-client/opera-developer: Old (diff)
downloadgentoo-1fe53bfdfa625625f3157581e9f3a6b21875eb67.tar.gz
gentoo-1fe53bfdfa625625f3157581e9f3a6b21875eb67.tar.bz2
gentoo-1fe53bfdfa625625f3157581e9f3a6b21875eb67.zip
dev-python/pysnmp: Version 4.4.10
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-python/pysnmp/Manifest1
-rw-r--r--dev-python/pysnmp/pysnmp-4.4.10.ebuild52
-rw-r--r--dev-python/pysnmp/pysnmp-999999.ebuild2
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/pysnmp/Manifest b/dev-python/pysnmp/Manifest
index 559109e2f8dd..9d2009eaa570 100644
--- a/dev-python/pysnmp/Manifest
+++ b/dev-python/pysnmp/Manifest
@@ -1,3 +1,4 @@
+DIST pysnmp-4.4.10.tar.gz 438845 BLAKE2B 2ad444212d202a3e788b1cd2e4e95931ef59e758923ede9b99fe511fac9cd31b8ad02ebbd61fd2df4dec0b9f95eded2753465929aba3b070ca614353eae466d4 SHA512 ed7d705dda376bbf31366653566f1f85ffd71a8253e573ad197a8a073a60ec4fac356b28daf97ff1310121ea3a6b2fee17c843c6ca90d664916fd9095a462207
DIST pysnmp-4.4.4.tar.gz 436318 BLAKE2B 6e6616a79fc15d457b8da2e2260c65d9d8ef29888c033d80f2f47c8de035d0cff73dc4be1eeced8ef36dac1301b7da0d845837b780815792f545b6ad18d5496e SHA512 960ac73b7356bb236d3853432c094d3aa86a343f5e211065689e6c784293748ec6f2c1c17bf9d96b4cbe2d9d476ebbacbaff4bed7d86370e5ef61e6f03ba8c0e
DIST pysnmp-4.4.8.tar.gz 435494 BLAKE2B 801d52660af23f9db9fd6e4fbd7b93f06db65d1c4987d44239da0927a116559ba502f295a5ba345529f15a41971a0f407b60266ef0cbcb328476e7e58e3646e0 SHA512 a4b0954a65818e49ce76455ef48c7c363bbc69031b699b303e8e301e7aa5db10ac5042557cc1727e885b200672ba35aef995baadb989cd95aa90e528c7e97e04
DIST pysnmp-4.4.9.tar.gz 436017 BLAKE2B 4fa4d1cab4e783542164d8bc5313e2b900cad9fec42e3bd6bc37239514d279d849ee857b3c9c01021750773e02ce951da600f5fbf8676efe31c3bdf580b99f12 SHA512 0832abb4134b77d43f6c750ce6c797c976b5fb99ef02602e7aa6034e4524e229eb33ac5d5b086acfb5740893120eb5b17df648dda48decc5d038476270e5fe1e
diff --git a/dev-python/pysnmp/pysnmp-4.4.10.ebuild b/dev-python/pysnmp/pysnmp-4.4.10.ebuild
new file mode 100644
index 000000000000..353b4e38c5de
--- /dev/null
+++ b/dev-python/pysnmp/pysnmp-4.4.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python SNMP library"
+HOMEPAGE="http://snmplabs.com/pysnmp/ https://pypi.org/project/pysnmp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ >=dev-python/pyasn1-0.2.3[${PYTHON_USEDEP}]
+ dev-python/pysmi[${PYTHON_USEDEP}]
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ default
+
+ if use doc; then
+ touch docs/source/conf.py
+ emake -C docs html
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/* )
+ docinto examples
+ use examples && dodoc -r examples/* docs/mibs
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "You may also be interested in the following packages: "
+ elog "dev-python/pysnmp-apps - example programs using pysnmp"
+ elog "dev-python/pysnmp-mibs - IETF and other mibs"
+ elog "dev-python/pysmi - to dump MIBs in python format"
+}
diff --git a/dev-python/pysnmp/pysnmp-999999.ebuild b/dev-python/pysnmp/pysnmp-999999.ebuild
index e8f0a0b95e67..f1a43eb17f04 100644
--- a/dev-python/pysnmp/pysnmp-999999.ebuild
+++ b/dev-python/pysnmp/pysnmp-999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
inherit distutils-r1 git-r3
DESCRIPTION="Python SNMP library"