summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-12 10:40:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-12 10:41:45 -0500
commit1ff4958f9004d3b42f63aaba244a2d8e04412743 (patch)
treed45402b0ec763445c3ff4c81d667d70ff98bdc37
parentapp-crypt/acme: 0.36.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-1ff4958f.tar.gz
gentoo-1ff4958f.tar.bz2
gentoo-1ff4958f.zip
app-crypt/certbot: 0.36.0 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.35.0.ebuild48
-rw-r--r--app-crypt/certbot/certbot-0.36.0.ebuild2
3 files changed, 1 insertions, 50 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index b51d00340383..6a90571bec86 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,3 +1,2 @@
-DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
DIST certbot-0.37.0.tar.gz 1327246 BLAKE2B 917360ab6d9dedd6e5ea2c558822c228ff34617f97341b7d176e69f7589a3aa3012f1d9abdb33b72960c68a80b29987d1a7b1121eadd7d93adec5829b316f326 SHA512 3f2df5f591ba241719fe2e5e90c2b87e2d932d991d943eefbe00b9d76f7fb056d3b6026879511f591473c698b798e78645879f018a78e503b8a06280b036cb35
diff --git a/app-crypt/certbot/certbot-0.35.0.ebuild b/app-crypt/certbot/certbot-0.35.0.ebuild
deleted file mode 100644
index 13fbbb720700..000000000000
--- a/app-crypt/certbot/certbot-0.35.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
- ${CDEPEND}
- >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
- >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
- >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # acme is not installed, removing it here is fine, the dir just confuses tests
- rm -R acme
- pytest -vv ${PN} || die
-}
diff --git a/app-crypt/certbot/certbot-0.36.0.ebuild b/app-crypt/certbot/certbot-0.36.0.ebuild
index c55679793511..4ed99381a016 100644
--- a/app-crypt/certbot/certbot-0.36.0.ebuild
+++ b/app-crypt/certbot/certbot-0.36.0.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} == 9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
fi
inherit distutils-r1