summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-06-07 16:04:31 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-15 00:48:31 +0200
commit1ff961607936aa6100100f61674fd82799765dc7 (patch)
tree7a7f9dd265d2af76af27a5951f2a65a8be71d7f7
parentsys-kernel/git-sources: Linux patch 5.8-rc1 (diff)
downloadgentoo-1ff961607936aa6100100f61674fd82799765dc7.tar.gz
gentoo-1ff961607936aa6100100f61674fd82799765dc7.tar.bz2
gentoo-1ff961607936aa6100100f61674fd82799765dc7.zip
lxqt-base/liblxqt: add version 0.15.1
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16111 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--lxqt-base/liblxqt/Manifest1
-rw-r--r--lxqt-base/liblxqt/liblxqt-0.15.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/lxqt-base/liblxqt/Manifest b/lxqt-base/liblxqt/Manifest
index 7bc2362781f6..b5957557e31e 100644
--- a/lxqt-base/liblxqt/Manifest
+++ b/lxqt-base/liblxqt/Manifest
@@ -1,2 +1,3 @@
DIST liblxqt-0.14.1.tar.xz 81704 BLAKE2B 9aa190fce337068d02962af90c1847acd51a63c44019c9ccdc729dea00d52cd65826e50850e913306f5e6f0a20d1e25b4f90cd09ebb9012c2c3337aaeaa3665f SHA512 28ce5e924d136f9907f84e40d4823c412df071009a9d5da4e061ce969d7575b21210d5178103f9bfc73baa87ccafc87dcb6e29a737467ca1a459c1fd3c1071ba
DIST liblxqt-0.15.0.tar.xz 80624 BLAKE2B 0f5b1fede9460dddd2a506e4945ad81c8e7121e74178833664b838c3acd88451a3c17e8e4db2e6a34e14ef0638760fee36273abb4c6d3f93014d402d069633c3 SHA512 6693be070fe641d590e3187abb2797ea470af5101efc4e9aed88a12cb28cc31aff60b6086cf717cd778353b50164d2365d88968a96a7fa00f6bc53e6855ddf7f
+DIST liblxqt-0.15.1.tar.xz 80040 BLAKE2B f729bf1b10a35b97d71f2e95a35999d3f246b4e59cdce25e32ab2a72ed5be50a443db0c841dcd0d41deb25e130c91cf75a5ba384ae4c1e6d92aa306e0b4eb75d SHA512 a0eb00ca5b228ef32d1a3952d3cb4702273dda16c9e70cc75046bfe1f51e5a7849d5306cca9d616ff82bd91715d97d703c458d406ba9e2425aa3fd26f155493c
diff --git a/lxqt-base/liblxqt/liblxqt-0.15.1.ebuild b/lxqt-base/liblxqt/liblxqt-0.15.1.ebuild
new file mode 100644
index 000000000000..70e3a186da24
--- /dev/null
+++ b/lxqt-base/liblxqt/liblxqt-0.15.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Common base library for the LXQt desktop environment"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ BSD"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+backlight"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.5.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5[X]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ backlight? ( sys-auth/polkit-qt )
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_BACKLIGHT_LINUX_BACKEND=$(usex backlight)
+ )
+ cmake_src_configure
+}