summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-10-21 18:48:19 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-10-22 13:33:08 +0200
commit1ffa52302834eac8460734dd8b84e9513ed8bcac (patch)
tree9073dbbe1d847a4ffcc56e0ec85e30bf888ec82a
parentnet-wireless/unifi: bump to 6.0.29 (diff)
downloadgentoo-1ffa5230283.tar.gz
gentoo-1ffa5230283.tar.bz2
gentoo-1ffa5230283.zip
app-text/diff-pdf: bump to 0.4.1
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--app-text/diff-pdf/Manifest1
-rw-r--r--app-text/diff-pdf/diff-pdf-0.4.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/diff-pdf/Manifest b/app-text/diff-pdf/Manifest
index 26aac9e3e9fb..043359cd99dc 100644
--- a/app-text/diff-pdf/Manifest
+++ b/app-text/diff-pdf/Manifest
@@ -1 +1,2 @@
DIST diff-pdf-0.3.tar.gz 132862 BLAKE2B bb3fa163337482785778fa7cbeab3e9f883d8537e4a905592eb20f4bb876597f500beaa2d9f13706887e1d340dd378c68c231b91a4dd478fb206b32f2cbd768c SHA512 b85585162b498c5abf14020ad04616ebdb5efce25b20604dab81c6068a036a818d7e10ddbbdb69d278d4b5a46ab9b9aa782a52e37f278f3e9db7b4d2259aaa08
+DIST diff-pdf-0.4.1.tar.gz 137715 BLAKE2B f77b7a690f2a99aa003c1a36015113f0b3355acc45346637535231f763aa733174eca6b1f962058c625e06176fa13868965b3b67ddf6ffe249202ff799051e37 SHA512 4b7b49d7008b5920be86af8398dea41933888677b66505af0ca4daecbd1662dc0b3c04e7b2631d86680cdae4b0b58d24bcd4ddc2b7589127b682d4b97a179b88
diff --git a/app-text/diff-pdf/diff-pdf-0.4.1.ebuild b/app-text/diff-pdf/diff-pdf-0.4.1.ebuild
new file mode 100644
index 000000000000..5b18231db4e7
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# No EAPI=7 support in wxwidgets.eclass.
+EAPI=6
+
+inherit wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="http://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:3.0[X]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ WX_GTK_VER="3.0"
+ setup-wxwidgets
+ default
+}