summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2021-01-01 22:27:08 -0600
committerErik Mackdanz <stasibear@gentoo.org>2021-01-01 22:27:41 -0600
commit201d2a6a7e1febc4c9f70a31ab5fce77226897d5 (patch)
treed034445ee596356ff4f069e40fc2d08adacced35
parentdev-tex/latex2html: bump to 2021 (diff)
downloadgentoo-201d2a6a.tar.gz
gentoo-201d2a6a.tar.bz2
gentoo-201d2a6a.zip
media-sound/upmpdcli: Bump to 1.5.7
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index 52fc720a8042..12761f4fa0a5 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1,2 +1,3 @@
DIST upmpdcli-1.5.2.tar.gz 550460 BLAKE2B e9905fb2f6c07d7374651fd0a9d7ec821d6ea25d4debe1b6e69bbf7def8b75d0b35b245a5e4ca2477832f71a9fe950f7f7635d1b6fc29add0e59405c0c69b338 SHA512 4d6cd44b64637c5a07996a416f0cf15e27e24b84aa04ee3ee9f6f5eda3164a5b964915587a4342cc0a8f95fa175dd106b99242de5c50d3cb603e48450694009e
DIST upmpdcli-1.5.5.tar.gz 550726 BLAKE2B 1a32f5a3126e037f6663ab60244d7af3fd7aeb79c5878ba1ca4d8029b97917a70f5b06a82e6006fcf14642b96cb5539488b3bba03860a2dd23e6bce0efe54bdc SHA512 90ce69b4ef004e1b5db3229b3bc99637ecba0f5f7e82d0e9f567da163295b4a572d059accbeb679194d1846eb822d48378acc743ee334ffd9859f3e025f6a0f3
+DIST upmpdcli-1.5.7.tar.gz 552203 BLAKE2B fe8e8aa3f4c777925dce2a143aec201462cb2da9e33f604d48848f27acc51fad42e1c626c17b5325918f0d1de1b37c1c456240f811af118b83bc7ce3260e0687 SHA512 ce86b8f9b4e7614433ab542facbf7452426b66bf026bb21ea0e868cde9b492b09a86ee8aa259a9353f2ede6a22d1055987986747aa8e284714c5e60f73a3a55a
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.7.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.7.ebuild
new file mode 100644
index 000000000000..90bdff1ab338
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.5.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+LICENSE="GPL-2"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="thirdparty"
+
+DEPEND="
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd
+ >=net-libs/libupnpp-0.20.0-r1
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/upmpdcli
+ acct-user/upmpdcli
+ app-misc/recoll
+ thirdparty? ( dev-python/requests )
+"
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit systemd/upmpdcli.service
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This package no longer assumes that upmpdcli is driving an"
+ einfo "mpd instance on the same host (https://bugs.gentoo.org/670130)."
+ einfo "Probably it is though, so be sure your mpd is built with"
+ einfo "USE=curl."
+ einfo
+ einfo "Consider installing media-sound/sc2mpd. If upmpdcli"
+ einfo "detects sc2mpd at run-time, capabilities are added"
+ einfo "including internet radio support. See upstream docs"
+ einfo "for more information."
+}