summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 18:41:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 18:41:56 -0700
commit201e4144c98e3e8708d280e330e6e7179e7374e6 (patch)
tree4cd12d517152789118dfa2e0515ba83d8c291e3d
parentdev-python/yappi-1.2.5: Version bump (diff)
downloadgentoo-201e4144.tar.gz
gentoo-201e4144.tar.bz2
gentoo-201e4144.zip
dev-python/yapf-0.30.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/yapf/Manifest1
-rw-r--r--dev-python/yapf/yapf-0.30.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/yapf/Manifest b/dev-python/yapf/Manifest
index 8817481376ad..ba5499e7852e 100644
--- a/dev-python/yapf/Manifest
+++ b/dev-python/yapf/Manifest
@@ -1 +1,2 @@
DIST yapf-0.28.0.tar.gz 157976 BLAKE2B 11dbbecd4a9cd77e6ff3f1f279cc4302b13445e3f0522f64a7e6b71155703f4c074a5bbf08cedc903533aeaee7338c63a98fc04870b8470a30377686dc66d2b4 SHA512 be9ed5278d085797aba4a582a37295716c76fd10a4cea4bb5090794dd53eba6d1340d8ba7508e33a146f189a863578c95b0a651bbfd90b0390076028e03ad9bf
+DIST yapf-0.30.0.tar.gz 168259 BLAKE2B 1c5955028531dbcc20870ef84f3ba225a203f94367edc4e7ee8245a641cd83de0e57b0d55a4c93e8ef6f7bbe8b56f26b06a257968e132a04beffd77a8f951d5f SHA512 a282213d0171671a24d44b7a00b69f65163e7a7b8edfbede5cc38c809236a71f7adc8bfc3c4a1d1e66ac3cb2d9c6bb54b1303a2875ec09cdaddaa71d2039f84b
diff --git a/dev-python/yapf/yapf-0.30.0.ebuild b/dev-python/yapf/yapf-0.30.0.ebuild
new file mode 100644
index 000000000000..5adb3c935492
--- /dev/null
+++ b/dev-python/yapf/yapf-0.30.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A formatter for Python files"
+HOMEPAGE="https://github.com/google/yapf"
+SRC_URI="https://github.com/google/yapf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py