summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-02 12:51:32 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-02 12:52:42 +0200
commit203070baa7d1fb5c1da5af3909d8f891e4852019 (patch)
tree8c68dd020cd6010b782970e9bc8bf155426d77b3
parentdev-python/black: explain lack of py3.11 support (diff)
downloadgentoo-203070ba.tar.gz
gentoo-203070ba.tar.bz2
gentoo-203070ba.zip
xfce-extra/xfce4-notifyd: Bump to 0.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest1
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index 7dbf6e86c40e..4903be85b82b 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1 +1,2 @@
DIST xfce4-notifyd-0.6.3.tar.bz2 547511 BLAKE2B 73aba96f6bd2116e87e20928ca74ff985ee74b8f39bca96de81e59ee5677bfacf9a2c78caa42ba43ece7e754fd7a8006ec1d3a507d89e4a2d6b4011d53e21d80 SHA512 9113018c238878c2584cb4221dd5aaaab9d8af5a86fb738f8f9deb863147343c0527582d8e45619bec3b7aaf3bbe045e41a33e306eacc20f946c971a8164935a
+DIST xfce4-notifyd-0.6.4.tar.bz2 554776 BLAKE2B f594ee8a841e4074592a6377e79fde8dd89574620a433a9813f4ad106d712361e941b443de481cb9d140a47e7b1b4753116b4f949c39b6834926f0708877fb6e SHA512 644e2e49092892e386a9f82edc6ab3b2b59ba67617d9217fb43dd3cf74ae5cfc9b9bea6ed0fab4c4440eca68613aa996d9f8dc73deb1f60926217b7db18cc73b
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild
new file mode 100644
index 000000000000..8273e159ed4c
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.56:2
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.10:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}