summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-09 09:20:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-09 09:28:11 +0100
commit2030768886b1b2bdaa939e36d9790e0ca06d446e (patch)
treeade928b6028a8f197234e9141a7126635a8d1849
parentmedia-gfx/viewnior: Stabilize 1.7-r2 x86, #774924 (diff)
downloadgentoo-2030768886b1b2bdaa939e36d9790e0ca06d446e.tar.gz
gentoo-2030768886b1b2bdaa939e36d9790e0ca06d446e.tar.bz2
gentoo-2030768886b1b2bdaa939e36d9790e0ca06d446e.zip
dev-python/pychm: Fix tests
Closes: https://bugs.gentoo.org/774963 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pychm/pychm-0.8.6.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pychm/pychm-0.8.6.ebuild b/dev-python/pychm/pychm-0.8.6.ebuild
index 90adc71074bd..3957210dc1f6 100644
--- a/dev-python/pychm/pychm-0.8.6.ebuild
+++ b/dev-python/pychm/pychm-0.8.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -19,3 +19,11 @@ RDEPEND="dev-libs/chmlib"
DEPEND="${RDEPEND}"
distutils_enable_tests pytest
+
+src_test() {
+ # need to avoid relative import of 'chm' directory but tests rely
+ # on locating files relatively via tests/...
+ mv tests .. || die
+ cd .. || die
+ distutils-r1_src_test
+}