summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2022-05-19 21:38:22 +0200
committerChristian Ruppert <idl0r@gentoo.org>2022-05-19 21:38:28 +0200
commit2044ed519519f25d337b6688b91e361e411f6386 (patch)
treeb0c91b93215b7cea99bf152f89ec54e3ce52ef83
parentdev-db/postgresql: Add zstd support in postgresql-15 (diff)
downloadgentoo-2044ed51.tar.gz
gentoo-2044ed51.tar.bz2
gentoo-2044ed51.zip
net-proxy/hatop: Python 3.10 support, bug 846173
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
-rw-r--r--net-proxy/hatop/Manifest1
-rw-r--r--net-proxy/hatop/hatop-0.8.0.ebuild31
-rw-r--r--net-proxy/hatop/hatop-0.8.1.ebuild4
3 files changed, 2 insertions, 34 deletions
diff --git a/net-proxy/hatop/Manifest b/net-proxy/hatop/Manifest
index f11c21b3b15e..a9cfc9193b75 100644
--- a/net-proxy/hatop/Manifest
+++ b/net-proxy/hatop/Manifest
@@ -1,2 +1 @@
-DIST hatop-0.8.0.tar.gz 134737 BLAKE2B bc5b1f878dc3ff388c788b6f4a07d9a3076ca3c2c11de15ec6d1ad17d5b2295162568791e4dc9e3edf091a08c80662ceb4d5a6d276e69dd3c96132cb78d007ee SHA512 1776da58a12835434d7b8f59582bad44fb3bf9479f05fedb45f84bc73792b331dda63f989c8b202436801a30600283ec782380e16aa75abf7643ffa5da029718
DIST hatop-0.8.1.tar.gz 136760 BLAKE2B 3692e9dd307d5f098bd3a66a3a75be5184e17d246dc94b3581d2742c9629d558dc4768baaef1c1e290825e57a651dccc926f22b4ecc98074cc8309fdda4b4b57 SHA512 25026ddd62ef43f02cfb3ef41a815adf232c8a4b3053e925dcea69696c207ffbf22966ce1177ef460071e683f5a4ec8d011d2bb2b0aa06f4a9b3e5932aae93b6
diff --git a/net-proxy/hatop/hatop-0.8.0.ebuild b/net-proxy/hatop/hatop-0.8.0.ebuild
deleted file mode 100644
index 2b54555e554b..000000000000
--- a/net-proxy/hatop/hatop-0.8.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="ncurses"
-
-inherit python-r1
-
-DESCRIPTION="Ncurses client and real-time monitoring and displaying of HAProxy status"
-HOMEPAGE="https://github.com/jhunt/hatop"
-SRC_URI="https://github.com/jhunt/hatop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}"
-
-src_install() {
- python_foreach_impl python_doscript bin/hatop
-
- doman man/hatop.1
-
- dodoc CHANGES.rst KEYBINDS README.rst
-}
diff --git a/net-proxy/hatop/hatop-0.8.1.ebuild b/net-proxy/hatop/hatop-0.8.1.ebuild
index 9b40160d20ed..15c530c52d75 100644
--- a/net-proxy/hatop/hatop-0.8.1.ebuild
+++ b/net-proxy/hatop/hatop-0.8.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="ncurses"
inherit python-r1