summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:16 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:11 +0000
commit204bfc7dc4be05334957e6ccc4041aa562b6fc5b (patch)
tree0c6622b3374837955a43c3f7e1b37ee2ee1ecd3b
parentgames-arcade/gnake: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-204bfc7dc4be05334957e6ccc4041aa562b6fc5b.tar.gz
gentoo-204bfc7dc4be05334957e6ccc4041aa562b6fc5b.tar.bz2
gentoo-204bfc7dc4be05334957e6ccc4041aa562b6fc5b.zip
games-arcade/stardork: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-arcade/stardork/stardork-0.7-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-arcade/stardork/stardork-0.7-r1.ebuild b/games-arcade/stardork/stardork-0.7-r1.ebuild
index d2458f6571f1..d2b7e070c095 100644
--- a/games-arcade/stardork/stardork-0.7-r1.ebuild
+++ b/games-arcade/stardork/stardork-0.7-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="An ncurses-based space shooter"
@@ -24,7 +25,7 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" LDLIBS="$(pkg-config ncurses --libs)" ${PN}
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) ncurses --libs)" ${PN}
}
src_install() {