summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-18 06:13:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-18 06:13:07 +0200
commit204e3130f96c8805f453f6c6c0746d0c98d3d578 (patch)
tree1555e04fd872151215b193096760659eafb36d16
parentx11-libs/libxcb: Stabilize 1.17.0 ppc64, #932100 (diff)
downloadgentoo-204e3130f96c8805f453f6c6c0746d0c98d3d578.tar.gz
gentoo-204e3130f96c8805f453f6c6c0746d0c98d3d578.tar.bz2
gentoo-204e3130f96c8805f453f6c6c0746d0c98d3d578.zip
dev-python/botocore: Bump to 1.34.108
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.108.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4768b0d2921a..5a93e607ca62 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.103.gh.tar.gz 13018336 BLAKE2B 84cef06d1eff09fc9e7d4480bc11be16c775e6aa21c300be21735d4bbf891618861a94e7fb52735c34f4f831220411d2b307546e930e77822d8c876dd05f7780 SHA512 f66c3959c5f323117127789d0a3492d5ecfcdfa371f2fdd3339bf1feb7cf1ba67ce7015014e49530f24a440d08a9b634d2ada85c1953ed438f70e5a6cca040f0
DIST botocore-1.34.107.gh.tar.gz 13028692 BLAKE2B ab26f39a43d1dad6b2ee7a99878a584601d0368bff65ef1beb0869a1272ce528074633091fd52f34ca839865f83c73b7be238666ccfa8975cbe2e83203f426e6 SHA512 59dcd1a4fe32bd61da81b02a78925cc11e010ccd98445c1073665d3de57a532cbc283dace6cd0772be7c366d5e859b2ea904ee5b197c7e395b75b7b795e13236
+DIST botocore-1.34.108.gh.tar.gz 13029228 BLAKE2B 947c11bb991e9e7622412bb7e90579e56d688b43ed836fb95ac133520221f56c2e96dc3a6d8b939d334ee4b4ad6ce8b30259c671be1bf9b3fc3deae62391674c SHA512 af23c80879d12cbb279741c216b99bf643b09ef516837275d31f6fbce253863027741b0cd6c815ae32bb6f41ebf0d33c8f2120ec81d6a3803cd0ffeab7be91e1
DIST botocore-1.34.98.gh.tar.gz 13008491 BLAKE2B 0b5c368264cc43c162d158b383535183c0fd0065dc6c5edfd3eaaab842d0607b3cc3b99860fa8dc4ef207b5be1457fce9d143723da29e262f30ecc82c5f9ba66 SHA512 39ccb0082ecd6ed6cc7d3f7cea01d39e8d5e92224e3290a66f86ed00562a1d858f75d006af725d2b857ac891f1b366300b7e4c2d24277d942b5a9b9e2cdba431
diff --git a/dev-python/botocore/botocore-1.34.108.ebuild b/dev-python/botocore/botocore-1.34.108.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.108.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}