summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-04 08:23:59 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-04 08:54:43 +0100
commit208078cb7d0e799883da855caf96ba6d71496001 (patch)
tree1747a777cca2cbd7c3ca60f33a272748434152b6
parentdev-util/pkgcheck: add perl use flag to live ebuild (diff)
downloadgentoo-208078cb.tar.gz
gentoo-208078cb.tar.bz2
gentoo-208078cb.zip
xfce-extra/xfce4-time-out-plugin: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-time-out-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/Manifest b/xfce-extra/xfce4-time-out-plugin/Manifest
index b5b3c66412e7..19a626ac0184 100644
--- a/xfce-extra/xfce4-time-out-plugin/Manifest
+++ b/xfce-extra/xfce4-time-out-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-time-out-plugin-1.0.3.tar.bz2 362390 BLAKE2B db7ba33a1d30dca7361d6ab6be5559786891273a36e00a028a0e27084d3fb4760af18f5cecc5c2edfd9a76640130ba4a4412d2228b26154f8b85173df360fa38 SHA512 c2080abef330e9f783b3e9c008a76d11bdbdfe1a666435237b6b06a50e93191a760441a9d343f24234eb4343b550009ed9e2101dbffbec3d8f53c562d4bb3cfc
+DIST xfce4-time-out-plugin-1.1.0.tar.bz2 395843 BLAKE2B cd5c49cc6bb31003803cc47b099847dc6d88bed9e36a7372b8d76b25a75bf28079afceda14ee235c724273cde2519fadb701bfd45995b10ea93b3d6b05cb359b SHA512 03d27d98a3968daf93357556a5ca63641ceee3ce9f53db5287ce27a282d3f4a068a2c9be14d7690d4188901245521c03b68bb3fe39e1ed0e1f6a95eecc1dc846
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.0.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.0.ebuild
new file mode 100644
index 000000000000..ffc66edafa2c
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-time-out-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}