summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-13 20:16:36 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-13 19:33:16 -0400
commit20adf21dd2ec24f5963797b4594d5f33323b01a6 (patch)
tree70ae32f34bb4c71b0154881126b6b131ff27b249
parentapp-text/pandoc-bin: Stabilize 3.1 amd64, #901097 (diff)
downloadgentoo-20adf21dd2ec24f5963797b4594d5f33323b01a6.tar.gz
gentoo-20adf21dd2ec24f5963797b4594d5f33323b01a6.tar.bz2
gentoo-20adf21dd2ec24f5963797b4594d5f33323b01a6.zip
sci-geosciences/gnome-maps: Version bump to 44_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30116 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--profiles/package.mask1
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-44_rc.ebuild51
3 files changed, 53 insertions, 0 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index cdac6d875c75..06d5c7c8a415 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -66,6 +66,7 @@ dev-ruby/net-http-persistent:3
>=net-libs/glib-networking-2.76_beta
>=net-misc/gnome-connections-44_rc
>=net-misc/gnome-remote-desktop-44_rc
+>=sci-geosciences/gnome-maps-44_rc
>=sys-apps/gnome-disk-utility-44_rc
>=sys-apps/xdg-desktop-portal-gnome-44_rc
>=x11-wm/mutter-44_rc
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index ed3e5c48fa73..9e7b0a66f375 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,2 +1,3 @@
DIST gnome-maps-43.2.tar.xz 2334324 BLAKE2B a8daacd9874e9b8d44ae6107b7cc1a0a4a168d579b4101e4da408c08e2509f7da782605b27d089331d3628584783f3fd1d43c26d3bc7b09325810dec7b9b1648 SHA512 dfd7eba5fc0cc38152753d2d3b5ba13cdc614b96fe3f8e6629dc6c56515108fc6f2469f32629ffaba97667b15da294d874653d9133dd13592738379d5fb91c78
DIST gnome-maps-43.4.tar.xz 2335020 BLAKE2B 267b4a2a1c8273fdcdccd7f2b385b2c95aa8903d1f5e117affc2174c873931f01cba6d17bfcabd949eb91fbf960469517569a80acd8ecaa45de9a181a7cece9a SHA512 16efd035a940e5ffad6dbbd7d8e527c56fb088211c41d130c0441ae321ea89f3a60524a39dcc5de5bc1caaee408e0eb0fda504471002876b4f3550759939568f
+DIST gnome-maps-44.rc.tar.xz 2350924 BLAKE2B 3e0a6f418c77cf6d4dd0e49b279cff54f0e962ab1a789a8ea610a4f1204f47919f7ae003438784f00bce92c7e3823501763c7be68cdc2011b936458392fbe959 SHA512 528187886118b077b184e37d9cbb7eee8742366f5daac0121658ad506d556e1d7349a63d9cf2931db0b2245c8e59c91b0ce585c1da7cb2bb93559ae5fd9ea308
diff --git a/sci-geosciences/gnome-maps/gnome-maps-44_rc.ebuild b/sci-geosciences/gnome-maps/gnome-maps-44_rc.ebuild
new file mode 100644
index 000000000000..161a09e7bdb7
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-44_rc.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+SRC_URI="https://download.gnome.org/sources/${PN}/44/${PN}-44.rc.tar.xz"
+S="${WORKDIR}/${PN}-44.rc"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}