summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Sartori <alberto.sartori86@gmail.com>2017-12-23 23:22:47 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-26 22:26:35 +0100
commit20c062d056d0d5a9fda5508648aa18e24f22f368 (patch)
treee70b5034222b6ff3ab5f643a2b0d214361da511f
parentdev-db/mongodb: amd64 stable wrt bug #643546 (diff)
downloadgentoo-20c062d0.tar.gz
gentoo-20c062d0.tar.bz2
gentoo-20c062d0.zip
app-misc/gcal: version bump to 4.1.
Closes: https://github.com/gentoo/gentoo/pull/6614
-rw-r--r--app-misc/gcal/Manifest1
-rw-r--r--app-misc/gcal/gcal-4.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/gcal/Manifest b/app-misc/gcal/Manifest
index dc2b46515889..6e5c89893fa8 100644
--- a/app-misc/gcal/Manifest
+++ b/app-misc/gcal/Manifest
@@ -1 +1,2 @@
DIST gcal-3.6.3.tar.xz 1640172 BLAKE2B 322a3bf34a389ab92daa0262b8b36f99b585c7f76e46e5a921a5e23ced74ae98bf09446e02988c98c29ecadf631b6624cb43e76c8da736a185e52ed34441c334 SHA512 9be7d6e58a55fbb7531f91bd2a6fa51e8d62364636c31d8d65f6ac24415ac2de8af5eaab8496e155c2820b7480ecf926c4395114ff4363deb21bd268dec44963
+DIST gcal-4.1.tar.xz 1658948 BLAKE2B 980b509923d7e3afbd391f1129a77e647f61e09d68aec29490bc16041260e56082097732f015260515036a4560bee18391c8f6aaa5eaff69740f18a37a44d8f2 SHA512 24b9ee87c3dbfd3231b2017fd0a3030cc5b7c7fde032ea1fcf816b0f10dc40d808c646aa8ece86651da4f3928fecf35f84f4c68c0bfdb8cf63e3ecc189d2074d
diff --git a/app-misc/gcal/gcal-4.1.ebuild b/app-misc/gcal/gcal-4.1.ebuild
new file mode 100644
index 000000000000..da50405b5703
--- /dev/null
+++ b/app-misc/gcal/gcal-4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Calendar - a replacement for cal"
+HOMEPAGE="https://www.gnu.org/software/gcal/"
+SRC_URI="mirror://gnu/gcal/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ncurses nls unicode"
+
+DEPEND="
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.17 )"
+
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
+
+src_configure() {
+ tc-export CC
+ append-cppflags -D_GNU_SOURCE
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable ncurses term) \
+ $(use_enable unicode)
+}