summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-21 22:36:02 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-21 22:36:02 -0400
commit20c4b16757cc2e9938b873a567c1c6c53345c438 (patch)
tree71241ca8ce8912d676340e11ece9ac75fe4a5fce
parentnet-fs/btfs: move from sys-fs/btfs (diff)
downloadgentoo-20c4b16757cc2e9938b873a567c1c6c53345c438.tar.gz
gentoo-20c4b16757cc2e9938b873a567c1c6c53345c438.tar.bz2
gentoo-20c4b16757cc2e9938b873a567c1c6c53345c438.zip
dev-python/llfuse: version bump to 1.1.1
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index d8e94afe42c7..b773c9fdfe57 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -3,4 +3,5 @@ DIST llfuse-0.41.tar.bz2 397155 SHA256 58079acce2ed03305bfea998cfad7c5d1815c85c2
DIST llfuse-0.42.1.tar.bz2 320282 SHA256 8ee9f190682d1c94e6522e77064fcdb4c7b07e71a6b9d1193ac1527972a98b59 SHA512 b87b26a3b19db954110248233f393c2c445d42b0fd89d83da3282d1f21f9ef6285721f3348e86d00d46584e3fc9896c6111d9573a103505476ab4f59d2c1b444 WHIRLPOOL c08d356e8170180aba87de9b5fb8f716a99865040582f90ec4a144c88b27f10f5e36ef4af20a29367cf3e4ae971a1a1b731e2717f7d1dece70754af49a4e535b
DIST llfuse-0.43.tar.bz2 323979 SHA256 550c23c99ab1da711e816bdd980d588de174e143bc96cdb1f11c6ae6af35c7a1 SHA512 d3dfd33898eefd5774d007c960ac72f6c7a509ad18b5fb520a07f8c9b23414ba3f171e7d36a8703cdb2421270c3a3da82626cb6be7eb0cb3840d29506926c73f WHIRLPOOL 07b9e181f48d2f6d512436c775011b81f5db2e144809c9010e3a6cb263be75ebea1bebac7ecd02e242214b31feb18bafc0b996d36b257db152762769bdb5f127
DIST llfuse-1.0.tar.bz2 323706 SHA256 fa521ce77a8c0ac1c8c21e6d4b0705dacc0ddd627439c2b3827c674909c027d2 SHA512 17d5fc91083dc29b11120980b68d000605582a757bf61a09ce4b840105fe0dc2b6afa416d09bf2abf11fd3c8bcbd5dfa4d90a9c9cc955c80a38111fb594e8b06 WHIRLPOOL aa8d22d0e7c6f5121c981c3c4fe7999aada35fa3bd5189c1ea14715366880af40105e8c35b4da7a098df449b277761a8dc50c489e65a074de430227599f032ac
+DIST llfuse-1.1.1.tar.bz2 327071 SHA256 1b84b1152ae461e66ecc526d0de71eaec086c587e97d1dda93d620b16a92db6c SHA512 6541a55a740bac03edae8ce2562122e21655236c58c89cbb29b211a497c8a706ad79c7da485700b0842ba92fc8958799f62d552ce733aa8b3bfa8a6a3aa8c9a6 WHIRLPOOL d84b5108c0d6c25200f17709996c445d0fd2a3abbd37e54ece7e7a29b40f384da274a41ea7125ff84bb3932864d4d6dbf76372df96fa5b9d0cd33bb97c7cda2c
DIST llfuse-1.1.tar.bz2 326175 SHA256 e250d59f3ed0d91a6bdcf81ab8af5ade994de3abb96bc5e64cd465a8265e9ffb SHA512 8e468c35cf74ab25a17b17364bbb5b5c8ab02ab5f4fe911970792dc57b5a7d87bea3889a81ff8dafd4438de3ea1ec96ec974025a33f177c84347c0830c6e1432 WHIRLPOOL d49738f666478f0e267045df0a68435cdf7a12e95ead306ab678d6a56843ddd419be49d4bd8c76990b21b08e051f0ae7e5bf641d94c69c4ccc2e989f73711024
diff --git a/dev-python/llfuse/llfuse-1.1.1.ebuild b/dev-python/llfuse/llfuse-1.1.1.ebuild
new file mode 100644
index 000000000000..755d02cc1a91
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}