summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 22:15:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-02 23:01:34 +0200
commit20ee457bdfc0f2d14a03e0c7ee272a1480f79009 (patch)
tree326ed3dfcc7edcb3eff75c749f963660a2698c0d
parentdev-python/pytest-rerunfailures: Bump to 10.1 (diff)
downloadgentoo-20ee457b.tar.gz
gentoo-20ee457b.tar.bz2
gentoo-20ee457b.zip
dev-python/python-xlib: Bump to 0.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-xlib/Manifest1
-rw-r--r--dev-python/python-xlib/python-xlib-0.31.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-xlib/Manifest b/dev-python/python-xlib/Manifest
index 223f83a26535..59b8a6f2b508 100644
--- a/dev-python/python-xlib/Manifest
+++ b/dev-python/python-xlib/Manifest
@@ -1 +1,2 @@
DIST python-xlib-0.30.tar.bz2 211256 BLAKE2B 979a004f6ff6ac933baa41623b346c8d1fa9944bc771308e3dd527de7ae6aebb8df0c5d269f21e7aca590ad7d3981d0deeb592981b0672c54b30ce286e650236 SHA512 52ee01cce73f024d6fdc995cff38ba9ff2838888aced12186a754c1760228f89209c1d6fc9d4fe0e371a4a43743f8fdfdef6ea32ea3feda5a85055897aaf887d
+DIST python-xlib-0.31.tar.bz2 211425 BLAKE2B c0a15b11c264942479c86088d8d5bdc0c759ae71df8939feee200ff58ec30d3b2c0a99a119cc56e5c32279b26517e7925cf9124a367dc7d32fcaf0be4f7cd41e SHA512 f98978cd0058ae18f08f9da71b4ff31cd7811040ec1eb03ce065c187f312259d674dd76aad447752c8f508e585838948c90182eef5d5240e6c06b0a5dd1fbd33
diff --git a/dev-python/python-xlib/python-xlib-0.31.ebuild b/dev-python/python-xlib/python-xlib-0.31.ebuild
new file mode 100644
index 000000000000..3a429851f290
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.31.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( sys-apps/texinfo )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+python_compile_all() {
+ use doc && emake -C doc/info
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_install_all() {
+ use doc && doinfo doc/info/*.info
+ distutils-r1_python_install_all
+}